Pertanyaan Mendeley desktop tidak akan berfungsi pada ubuntu 16.04


Saya sudah mencoba menginstal Mendeley di ubuntu 16.04. Saya mengikuti panduan instalasi di situs web mereka tetapi itu tidak dimulai. Ikon muncul ketika saya menjalankannya dan dalam 3 detik itu menghilang. Ada pikiran apa?

Output berlari mendeleydesktop di terminal

Unable to use Qt libraries in /usr/lib/x86_64-linux-gnu. Some components are missing:
 /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4 To run Mendeley Desktop you may need to install the QtWebKit and QtSvg packages provided by your Linux distribution. Using bundled SSL runtime libraries /usr/bin/../../opt/mendeleydesktop/bin/mendeleydesktop: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory 

12
2018-06-01 07:06


asal


Bisakah Anda menambahkan URL proyek dan nama paket ke posting asli Anda (dengan mengeditnya). saya tidak dapat menemukan paket apa pun yang disebut mendeley di 16.04 repositori. Saya menganggap Anda berbicara tentang mendeley.com - dufte
Jika aplikasi tampaknya macet sering membantu untuk memulainya dari terminal / commandline. Keuntungannya mungkin karena itu menghasilkan beberapa kode kesalahan atau serupa yang mungkin menjadi titik awal yang baik dalam pencarian solusi. - dufte
Ini dimulai di sini dengan benar pada 16.04 dan menampilkan dialog login dengan opsi register dan signin. - dufte
Bekerja untuk saya juga di gnome-1604, buka terminal dan jalankan mendeleydesktop dan tambahkan setiap dan semua output ke pertanyaan. - Mark Kirby
Instruksi di mendeley.com/download-mendeley-desktop/ubuntu/instructions bekerja untuk saya di Ubuntu 16.04. - edwinksl


Jawaban:


Buka terminal dan jalankan

sudo apt-get install libqtsvg4-perl libqtwebkit4

Saya memiliki kesalahan ini dan setelah jawaban Mark Kirby saya masih punya masalah. Setelah menjalankan di atas, sekarang Mendeley meluncurkan dan menyinkronkan semua data saya (ya!).

Apa yang saya tidak tahu adalah apakah itu hanya apa yang saya tulis di atas atau jika Anda membutuhkan ini dan juga jawaban Mark Kirby keduanya.

Sumber jawaban: http://ubuntuforum-br.org/index.php?topic=120046.0


12
2018-06-02 12:09



Saya bisa membuatnya bekerja hanya menggunakan perintah Anda tanpa menggunakan yang dari jawaban Mark Kirby. - adamconkey
@aconkey Terima kasih telah memposting ini. Saya yakin itu akan membantu seseorang di masa depan. - John


Anda tampaknya kehilangan beberapa dependensi qtwebkit dan qtsvg

Buka terminal dan jalankan

sudo apt install qt4-dev-tools

Sekarang coba jalankan lagi.


4
2018-06-01 15:28



dapatkan ini: 'libqt5webkit5 sudah versi terbaru' - manutsa
Coba versi terbaru ini. - Mark Kirby
Saya memiliki kesalahan yang sama persis dengan OP. Ini tidak memperbaikinya. Itu menginstal alat tetapi kesalahan yang saya dapatkan masih sama (seperti dalam pertanyaan). Ada ide lain? - John
Saya mengambil ini dari stack overflow jika ini tidak berhasil, jalankan sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev @John Sama kesalahan tetapi aplikasi yang berbeda stackoverflow.com/questions/26869830/… - Mark Kirby
Terima kasih @MarkKirby. Setelah menerapkan jawaban saya, itu berhasil. Saya tidak yakin apakah solusi ekstra Anda juga akan melakukan trik (juga seperti OP, saya cukup newbie). - John


Untuk menginstal persyaratan minimum pada Ubuntu 16.04 ikuti:

sudo apt-get install libqtwebkit4 libqt4-svg

1
2017-07-11 22:07





Saya tidak dapat berkomentar tentang jawabannya karena saya tidak memiliki poin reputasi yang cukup. Saya hanya ingin mengatakan bahwa jawabannya tidak bekerja untuk saya tetapi menginstal gdebi

sudo apt install gdebi

dari 16.04 Tidak dapat menginstal apa pun dari pusat Ubuntu Software dan menginstal melalui gdebi dengan mengklik kanan file .deb dan membuka dengan gdebi berfungsi dengan baik.

Juga jika Anda mengacaukan instalasi (seperti yang saya lakukan), Anda dapat menginstal ulang menggunakan gdebi.


0
2017-09-26 09:55