Pertanyaan Subproses skrip post-install yang diinstal mengembalikan status keluar error 247


Ketika saya ingin menginstal paket apa pun, saya mendapatkan ini:

root@kd32206:~# apt-get install nginx
Reading package lists... Done
Building dependency tree
Reading state information... Done
nginx is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
203 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up gconf2 (2.28.1-6) ...
dpkg: error processing gconf2 (--configure):
 subprocess installed post-installation script returned error exit status 247
dpkg: dependency problems prevent configuration of libgweather-common:
 libgweather-common depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgweather-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgweather1:
 libgweather1 depends on libgweather-common (>= 2.24.0); however:
  Package libgweather-common is not configured yet.
dpkg: error processing libgweather1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution-data-server:
 evolution-data-server depends on libgweather1 (>= 2.30.0); however:
  Package libgweather1 is not configured yet.
dpkg: error processing evolution-data-server (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent conficonfigured to not write apport reports
                                                                             configured to not write apport reports
                                   configured to not write apport reports
                                                                         configured to not write apport reports
                               configured to not write apport reports
                                                                     configured to not write apport reports
                           configured to not write apport reports
                                                                 configured to not write apport reports
                       configured to not write apport reports
                                                             configured to not write apport reports
                   configured to not write apport reports
                                                         configured to not write apport reports
               configured to not write apport reports
                                                     guration of evolution:
 evolution depends on libgweather1 (>= 2.30.0); however:
  Package libgweather1 is not configured yet.
 evolution depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
 evolution depends on evolution-data-server (>= 2.30.3); however:
  Package evolution-data-server is not configured yet.
 evolution depends on evolution-data-server (<< 2.31); however:
  Package evolution-data-server is not configured yet.
dpkg: error processing evolution (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of at-spi:
 at-spi depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing at-spi (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of baobab:
 baobab depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing baobab (--configure):
 dependency problems configured to not write apport reports
                                                           configured to not write apport reports
                 configured to not write apport reports
                                                       configured to not write apport reports
             configured to not write apport reports
                                                   configured to not write apport reports
         configured to not write apport reports
                                               configured to not write apport reports
     - leaving unconfigured
dpkg: dependency problems prevent configuration of brasero-common:
 brasero-common depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing brasero-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libbrasero-media0:
 libbrasero-media0 depends on brasero-common (>= 2.30); however:
  Package brasero-common is not configured yet.
 libbrasero-media0 depends on brasero-common (<< 2.31); however:
  Package brasero-common is not configured yet.
dpkg: error processing libbrasero-media0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of brasero:
 brasero depends on libbrasero-media0 (= 2.30.3-2); however:
  Package libbrasero-media0 is not configured yet.
 brasero depends on brasero-common (>= 2.30); however:
  Package brasero-common is not configured yet.
 brasero depends on brasero-common (<< 2.31); however:
  Package brasero-common is not configured yet.
dpkg: error processing brasero (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of capplets-data:
 capplets-data depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing capplets-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cheese-common:
 cheese-common depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing cheese-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-good:
 gstreamer0.10-plugins-good depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing gstreamer0.10-plugins-good (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cheese:
 cheese depends on cheese-common (= 2.30.1-2); however:
  Package cheese-common is not configured yet.
 cheese depends on gstreamer0.10-plugins-good (>= 0.10.23); however:
  Package gstreamer0.10-plugins-good is not configured yet.
dpkg: error processing cheese (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomevfs2-common:
 libgnomevfs2-common depends on gconf2 (>= 2.12.1-1); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgnomevfs2-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomevfs2-0:
 libgnomevfs2-0 depends on libgnomevfs2-common (>= 1:2.24); however:
  Package libgnomevfs2-common is not configured yet.
 libgnomevfs2-0 depends on libgnomevfs2-common (<< 1:2.25); however:
  Package libgnomevfs2-common is not configured yet.
dpkg: error processing libgnomevfs2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome2-common:
 libgnome2-common depends on gconf2 (>= 2.12.1-1); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgnome2-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome2-0:
 libgnome2-0 depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
 libgnome2-0 depends on libgnome2-common (>= 2.30); however:
  Package libgnome2-common is not configured yet.
 libgnome2-0 depends on libgnome2-common (<< 2.31); however:
  Package libgnome2-common is not configured yet.
dpkg: error processing libgnome2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libbonoboui2-0:
 libbonoboui2-0 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
dpkg: error processing libbonoboui2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomeui-0:
 libgnomeui-0 depends on libbonoboui2-0 (>= 2.15.1); however:
  Package libbonoboui2-0 is not configured yet.
 libgnomeui-0 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
 libgnomeui-0 depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
dpkg: error processing libgnomeui-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dasher-data:
 dasher-data depends on gconf2 (>= 2.10.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing dasher-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dasher:
 dasher depends on libbonoboui2-0 (>= 2.15.1); however:
  Package libbonoboui2-0 is not configured yet.
 dasher depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
 dasher depends on libgnomeui-0 (>= 2.22.0); however:
  Package libgnomeui-0 is not configured yet.
 dasher depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
 dasher depends on at-spi; however:
  Package at-spi is not configured yet.
 dasher depends on dasher-data (>= 4.11-1); however:
  Package dasher-data is not configured yet.
 dasher depends on dasher-data (<< 4.12); however:
  Package dasher-data is not configured yet.
dpkg: error processing dasher (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpanel-applet2-0:
 libpanel-applet2-0 depends on libbonoboui2-0 (>= 2.15.1); however:
  Package libbonoboui2-0 is not configuconfigured to not write apport reports
                                                                             configured to not write apport reports
                                   configured to not write apport reports
                                                                         configured to not write apport reports
                               configured to not write apport reports
                                                                     configured to not write apport reports
                           configured to not write apport reports
                                                                 configured to not write apport reports
                       configured to not write apport reports
                                                             configured to not write apport reports
                   configured to not write apport reports
                                                         configured to not write apport reports
               configured to not write apport reports
                                                     red yet.
dpkg: error processing libpanel-applet2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gnome2:
 python-gnome2 depends on libbonoboui2-0 (>= 2.15.1); however:
  Package libbonoboui2-0 is not configured yet.
 python-gnome2 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
 python-gnome2 depends on libgnomeui-0 (>= 2.22.0); however:
  Package libgnomeui-0 is not configured yet.
 python-gnome2 depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
dpkg: error processing python-gnome2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gnomeapplet:
 python-gnomeapplet depends on libbonoboui2-0 (>= 2.15.1); however:
  Package libbonoboui2-0 is not configured yet.
 python-gnomeapplet depends on libgnome2-0 (>= 2.17.3); however:
configured to not write apport reportsd yet.
                                      configured to not write apport reports
                                                                            configured to not write apport reports
                                  configured to not write apport reports

                                                                         python-gnomeapplet depends on libgnomeui-0 (>= 2.22.0); however:
  Package libgnomeui-0 is not configured yet.
 python-gnomeapplet depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
 python-gnomeapplet depends on libpanel-applet2-0 (>= 2.28.0); however:
  Package libpanel-applet2-0 is not configured yet.
 python-gnomeapplet depends on python-gnome2; however:
  Package python-gnome2 is not configured yet.
dpkg: error processing python-gnomeapplet (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of deskbar-applet:
 deskbar-applet depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
 deskbar-applet depends on python-gnomeapplet; however:
  Package python-gnomeapplet is not configured yet.
dpkg: error processing deskbar-applet (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ekiga:
 ekiga depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
 ekiga depends on evolution-data-server; however:
  Package evolution-data-server is not configured yet.
dpkg: error processing ekiga (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgstfarsight0.10-0:
 libgstfarsight0.10-0 depends on gstreamer0.10-plugins-good (>= 0.10.8); however:
  Package gstreamer0.10-plugins-good is not configured yet.
dpkg: error processing libgstfarsight0.10-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libtelepathy-farsight0:
 libtelepathy-farsight0 depends on libgstfarsight0.10-0 (>= 0.0.3); however:
  Package libgstfarsight0.10-0 is not configured yet.
dpkg: error processing libtelepathy-farsight0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of empathy:
 empathy depends on libgstfarsight0.10-0 (>= 0.0.1); however:
  Package libgstfarsight0.10-0 is not configured yet.
 empathy depends on libtelepathy-farsight0 (>= 0.0.6); however:
  Package libtelepathy-farsight0 is not configured yet.
 empathy depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing empathy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of eog:
 eog depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing eog (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of epiphany-browser-data:
 epiphany-browser-data depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing epiphany-browser-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of epiphany-browser:
 epiphany-browser depends on epiphany-browser-data (>= 2.30); however:
  Package epiphany-browser-data is not configured yet.
 epiphany-browser depends on epiphany-browser-data (<< 2.31); however:
  Package epiphany-browser-data is not configured yet.
dpkg: error processing epiphany-browser (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of epiphany-extensions:
 epiphany-extensions depends on epiphany-browser (>= 2.30.2); however:
  Package epiphany-browser is not configured yet.
 epiphany-extensions depends on epiphany-browser (<< 2.31); however:
  Package epiphany-browser is not configured yet.
dpkg: error processing epiphany-extensions (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evince:
 evince depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing evince (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution-exchange:
 evolution-exchange depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
 evolution-exchange depends on evolution (>= 2.30.0); however:
  Package evolution is not configured yet.
 evolution-exchange depends on evolution (<< 2.31.0); however:
  Package evolution is not configured yet.
dpkg: error processing evolution-exchange (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution-webcal:
 evolution-webcal depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing evolution-webcal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of file-roller:
 file-roller depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing file-roller (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcalctool:
 gcalctool depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing gcalctool (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gconf-editor:
 gconf-editor depends on gconf2 (>= 2.10.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing gconf-editor (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgksu2-0:
 libgksu2-0 depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgksu2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gksu:
 gksu depends on libgksu2-0 (>= 2.0.8); however:
  Package libgksu2-0 is not configured yet.
dpkg: error processing gksu (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gdebi:
 gdebi depends on gksu (>= 2.0.0-1ubuntu3); however:
  Package gksu is not configured yet.
dpkg: error processing gdebi (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problconfigured to not write apport reports
                                                            configured to not write apport reports
                  configured to not write apport reports
                                                        configured to not write apport reports
              configured to not write apport reports
                                                    configured to not write apport reports
          configured to not write apport reports
                                                configured to not write apport reports
      configured to not write apport reports
                                            configured to not write apport reports
  configured to not write apport reports
                                        configured to not write apport reports
                                                                              configured to not write apport reports
                                    ems prevent configuration of gedit:
 gedit depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing gedit (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-about:
 gnome-about depends on python-gnome2; however:
  Package python-gnome2 is not configured yet.
dpkg: error processing gnome-about (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-applets-data:
 gnome-applets-data depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing gnome-applets-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel-data:
 gnome-panel-data depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing gnome-panel-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on libbonoboui2-0 (>= 2.15.1); however:
  Package libbonoboui2-0 is not configured yet.
 gnome-panel depends on libgweather1 (>= 2.30.0); however:
  Package libgweather1 is not configured yet.
 gnome-panel depends on libpanel-applet2-0 (>= 2.28.0); however:
  Package libpanel-applet2-0 is not configured yet.
 gnome-panel depends on gnome-panel-data (>= 2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 2.31); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-about (>= 2.10.0-1); however:
  Package gnome-about is not configured yet.
 gnome-panel depends on python-gnome2; however:
  Package python-gnome2 is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-applets:
 gnome-applets depends on libbonoboui2-0 (>= 2.15.1); however:
  Package libbonoboui2-0 is not configured yet.
 gnome-applets depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
 gnome-applets depends on libgweather1 (>= 2.30.0); however:
  Package libgweather1 is not configured yet.
 gnome-applets depends on libpanel-applet2-0 (>= 2.28.0); however:
  Package libpanel-applet2-0 is not configured yet.
 gnome-applets depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
 gnome-applets depends on gnome-applets-data (>= 2.30); however:
  Package gnome-applets-data is not configured yet.
 gnome-applets depends on gnome-applets-data (<< 2.31); however:
  Package gnome-applets-data is not configured yet.
 gnome-applets depends on gnome-panel (>= 2.13.4); however:
  Package gnome-panel is not configured yet.
dpkg: error processing gnome-applets (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomekbd-common:
 libgnomekbd-common depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgnomekbd-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomekbd4:
 libgnomekbd4 depends on libgnomekbd-common (>= 2.30.2-2); however:
  Package libgnomekbd-common is not configured yet.
dpkg: error processing libgnomekbd4 (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
Errors were encountered while processing:
 gconf2
 libgweather-common
 libgweather1
 evolution-data-server
 evolution
 at-spi
 baobab
 brasero-common
 libbrasero-media0
 brasero
 capplets-data
 cheese-common
 gstreamer0.10-plugins-good
 cheese
 libgnomevfs2-common
 libgnomevfs2-0
 libgnome2-common
 libgnome2-0
 libbonoboui2-0
 libgnomeui-0
 dasher-data
 dasher
 libpanel-applet2-0
 python-gnome2
 python-gnomeapplet
 deskbar-applet
 ekiga
 libgstfarsight0.10-0
 libtelepathy-farsight0
 empathy
 eog
 epiphany-browser-data
 epiphany-browser
 epiphany-extensions
 evince
 evolution-exchange
 evolution-webcal
 file-roller
 gcalctool
 gconf-editor
 libgksu2-0
 gksu
 gdebi
 gedit
 gnome-about
 gnome-applets-data
 gnome-panel-data
 gnome-panel
 gnome-applets
 libgnomekbd-common
 libgnomekbd4
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

11
2018-04-17 09:42


asal


Coba sudo apt-get install ini akan menjalankan perintah sebagai administrator - viktorstrate
Anda merusak sistem Anda. - Avinash Raj
@AvinashRaj bagaimana cara memperbaikinya? bagaimana menginstal ulang? - user269828


Jawaban:


Setting up gconf2 (2.28.1-6) ...
dpkg: error processing gconf2 (--configure):
 subprocess installed post-installation script returned error exit status 247

Ini berarti bahwa postinst skrip untuk gconf2 paket gagal. Anda dapat memeriksa mengapa menggunakan:

dpkg --configure -D 777 gconf2

Anda juga bisa menjalankan postinst skrip sendiri:

sh -x /var/lib/dpkg/info/gconf2.postinst configure 2.28.1-6

Dan cari tahu apa yang salah.


20
2018-04-17 12:41





Maka cobalah

sudo apt-get purge nginx
sudo apt-get autoremove

untuk sepenuhnya menghapus paket dan kemudian mengetik

sudo apt-get install nginx-*

untuk menginstalnya lagi


2
2018-04-17 10:14



masih kesalahan yang sama - user269828
apakah hal yang sama terjadi dengan paket lain? - viktorstrate


temukan file paket package.postinst Anda di direktori / var / lib / dpkg / info dan hapus

#
 karakter sebelumnya
set -x
 dan api
dpkg --sikonfigurasi paket
 perintah dan lihat apa yang terjadi.


2
2017-12-03 07:24



Bisa juga set -e. Penjelasan untuk yang penasaran: set -e opsi menyebabkan shell untuk keluar jika ada perintah atau pipeline mengembalikan status bukan nol. - Tigran Saluev