Pertanyaan Perangkat Penyimpanan USB Automount


Di bawah Ubuntu 10.04 salah satu masalah yang muncul adalah bahwa perangkat USB tidak akan lagi secara otomatis me-mount ketika terpasang. Biasanya saya akan mendapatkan pesan pop-up yang menanyakan aplikasi apa yang ingin saya buka perangkat yang baru dicolokkan, namun sekarang itu tidak terjadi.

Ini terjadi terlepas dari cara perangkat diformat (NTFS atau FAT32) dan semua perangkat USB lainnya (printer, keyboard dan mouse) bekerja dengan sempurna.

Solusi saya saat ini adalah memasangnya secara manual sudo mount dev/... /medai/... Namun sejujurnya saya hanya lelah karena harus melakukan ini.

Saya senang untuk memposting informasi tambahan yang mungkin Anda butuhkan. Saya tahu akan ada banyak tempat yang dapat saya cari untuk mencari tahu apa yang salah tetapi saya tidak tahu harus mulai dari mana.


11
2017-09-08 22:02


asal


Saya akan mulai dengan melihat apakah ada entri log masuk ~/.xsession-errors, /var/log/daemon atau /var/log/kern ketika Anda memasang perangkat ... - poolie
@poolie Tidak ada yang jelas. Banyak "tidak ada rute untuk menjadi tuan rumah" di dalam satu sesi sekalipun - matto1990
Apakah itu juga terjadi ketika Anda boot dari live-cd atau live-usb? Ini seluruh pernyataan 'saya ditingkatkan ke', yang membuatnya cukup sulit untuk mengetahui hal ini. Apakah ini instalasi baru? Atau apakah ubuntu yang disesuaikan, mungkin dengan sekelompok PPA, yang Anda tingkatkan? - Ralf
@Ralf Maaf, itu sebenarnya adalah instalasi baru. Saya lupa saya mencoba hanya melakukan pembaruan tetapi rusak dan akhirnya hanya melakukan instalasi baru. Saya akan memperbarui pertanyaan untuk mencerminkan ini. - matto1990


Jawaban:


Terpecahkan, setidaknya untuk saya.

Saya pikir ini adalah masalah perangkat keras, karena saya mencoba live CD 12.04 di desktop saya dan semuanya berfungsi dengan baik. Saya mencoba laptop saya dan tidak membuka USB secara otomatis.

Apapun solusi yang saya temukan adalah menginstal usbmount dengan menjalankan perintah di bawah ini pada terminal:

sudo apt-get install usbmount

Kemudian USB terpasang dengan baik dan otomatis.

Info lebih lanjut tentang ini halaman. Saya juga menginstal autofs.

Semoga ini berhasil untuk Anda.


2
2017-10-28 03:45





Di gconf-editor, lihat di bawah / apps / nautilus / preferences. Harus ada pengaturan yang disebut "media_automount". Pastikan itu dicentang. Ada juga opsi yang disebut "media_automount_open" yang dapat Anda atur jika Anda ingin membuka media di nautilus secara otomatis selain memasangnya.


1
2017-09-11 03:49



Keduanya sudah diperiksa dan masalahnya masih berlanjut - matto1990
Sial ... aku yakin - Nerdfest


Ada yang rusak dalam pembaruan yang saya kira. Coba jalankan:

sudo mkdir /dbos 
sudo fdisk -l
# find your memory stick
sudo mount /dev/sdc /dbos
# now your memory stick is in /dbos

1
2018-03-14 18:30





Ini terjadi pada saya di xubuntu. Ini digunakan untuk me-mount secara otomatis tetapi sekarang tidak. Solusi saya adalah saya menginstal paket tambahan yang disebut usbmount.

sudo apt-get install usbmount


0
2017-09-09 01:44



Saya sudah menginstalnya tetapi ketika saya mencolokkan perangkat yang pernah dipasang di folder usb <X>. - matto1990
Ini tampaknya menjadi masalah biasa: ubuntuforums.org/showthread.php?t=1468755 dan ubuntuforums.org/showthread.php?t=1470705 dan saya menemukan satu skrip yang secara otomatis me-mount format ntfs: webupd8.org/2010/04/ubuntu-script-to-automatically-mount.html. - sagarchalise


Jika Anda menjalankan (Alt + F2) "ubuntu-bug storage", masalah Anda adalah opsi pertama. Ini mungkin bukan bug, tetapi laporan bug akan menjadi cara termudah untuk mengatasinya.

Oh dan tolong kirimkan tautan ke laporan bug di sini jika Anda melakukannya.


0
2017-09-11 20:13



Saya telah melakukan itu dan launchpad menunjukkan bahwa bug ini sama dan saya tidak perlu memposting yang lain. Sepertinya ditandai sebagai tetap meskipun: S bugs.launchpad.net/ubuntu/+source/gvfs/+bug/435136 - matto1990


Kedengarannya seperti Anda sudah kehabisan sebagian besar perbaikan normal. Perbaikan paksa mungkin terjadi jika Anda masuk ke pengaturan BIOS Anda dan memverifikasi bahwa Anda memiliki 'boot dari removable / flash drive' diatur ke ON.

Jika disetel ke OFF dan Anda mengaktifkannya, mungkin boot dengan flash drive yang tidak dapat di-boot dalam port, sistem operasi mungkin terpaksa menetapkan ulang cara mengelola perangkat flash. Paling buruk itu mungkin memuntahkan kesalahan lain yang dapat menuntun Anda untuk mencari tahu apa yang salah.


0
2017-09-15 14:51



Masih tidak pada yang satu: '(Tidak ada kesalahan juga. Saya pikir itu hanya akan harus menjadi pekerjaan instal ulang lengkap :( - matto1990


Coba di Nautilus → Edit → Preferensi → Media


0
2017-09-08 22:39



Semuanya diatur untuk "bertanya apa yang harus dilakukan". Tidak apa-apa aku menebak. - matto1990


Ini adalah masalah yang diketahui dengan 10.04 jika Anda memiliki floppy drive. Berikut ini solusinya:

  1. Buka terminal (Ctrl+Alt+F2).
  2. Mengetik: gksu gedit /etc/fstab
  3. Tambah sebuah # sebelum garis yang mengandung fd0.
  4. Kemudian dalam tipe terminal: rmmod floppy

0
2017-09-12 03:47



Saya menggunakan laptop tanpa floppy drive dan tidak ada garis seperti itu di fstab saya. Apakah saya perlu garis di fstab untuk menunjuk ke perangkat yang dapat dilepas atau ini bukan untuk apa fstab? - matto1990
Tidak. Perangkat yang dapat dilepas tidak memerlukan baris dalam fstab. Hanya filesystem yang di-mount saat boot membutuhkannya. - Javier Rivera