Pertanyaan Netbeans 8.0.2 membeku saat startup pada Ubuntu 15.10 64bit


Saya baru saja menginstal Ubuntu 15.10 64bit pada Thinkpad saya dan semuanya berfungsi dengan baik, tetapi saya menginstal netbeans 8.0.2 dan ketika saya mencoba untuk meluncurkannya, itu membeku saat startup selama fase Memuat modul.

Saya telah membuka openjdk 8. Saya tidak mengerti masalah ini karena pada 15.04 32bit di komputer lain, ini bekerja dengan baik.

Ketika memulai netbeans dari baris perintah, pesannya adalah sebagai berikut:

chrisgaubla @ sokioute: ~ / netbeans-8.0.2 / bin $ sh netbeans

OpenJDK 64-Bit Server VM warning: mengabaikan opsi PermSize = 32m; dukungan telah dihapus pada 8.0


10
2017-10-24 10:15


asal


Saya juga, juga di 64bit. Aplikasi "tvbrowser" dan "mediathekview" membekukan juga - Masalah Java dengan 15.10? - Dino
Mulai Netbeans di terminal dan tambahkan pesan ke pertanyaan Anda. - A.B.
Ketika memulai dari terminal inilah yang saya dapatkan: chrisgaubla @ sokioute: ~ / netbeans-8.0.2 / bin $ sh netbeans OpenJDK 64-Bit Server VM warning: mengabaikan opsi PermSize = 32m; dukungan telah dihapus pada 8.0 - Christophe Gaudet-Blavignac
Sudahkah Anda mencoba mengedit /etc/java-8-openjdk/accessibility.properties dan mengomentari baris assistive_technologies = org.GNOME.Accessibility.AtkWrapper?
Setelah mengomentari baris dalam accessibility.properties seperti yang disebutkan di atas, Netbeans masih membeku sejak saya memperbarui ke Ubuntu 15.10. Itu akhirnya bisa melewati "Memuat modul" - saya meninggalkan ruangan dan memberikannya sekitar 20 menit. Ketika saya kembali ternyata Netbeans telah dimuat dengan baik, tetapi sistem saya benar-benar terkunci. Sebelumnya, ketika mencoba memuat Netbeans saya melihat bahwa itu mengelompokkan salah satu cpu saya dengan stabil pada 100%. Saya telah kehilangan seluruh pagi melawan ini. Saya akan kembali ke Ubuntu 15.04. - CompuSolver


Jawaban:


Sama disini. Java 8 build 1.8.0_66-internal-b01 sepertinya agak tidak stabil. Anda bisa menunggu build yang lebih baru tiba di Ubuntu (https://tracker.debian.org/news/720431) atau gunakan OpenJDK 7 untuk saat ini.

Edit:
Ini memang tampaknya menjadi masalah dengan OpenJDK 8, yang tampaknya masih ada adalah membangun 66-b17. Jika Anda membutuhkan Java 8, Anda dapat mengunduh JDK dari Oracle http://www.oracle.com/technetwork/java/javase/downloads dan set path ke JDK itu di file <netbeans direktori> /etc/netbeans.conf (parameter "netbeans_jdkhome"). Saya tidak dapat mereproduksi masalah dengan Oracle JDK.


4
2017-10-24 21:16



Hm, sayangnya masalah masih nampak terjadi dengan build 1.8.0_66-internal-b17. - binary


Untuk membuatnya bekerja dengan OpenJDK 8, edit /etc/java-8-openjdk/accessibility.properties dan komentar baris berikut

assistive_technologies=org.GNOME.Accessibility.AtkWrapper

seperti yang disarankan di sini: https://bugs.launchpad.net/ubuntu/+source/openjdk-8/+bug/1510009.


18
2017-10-29 19:04



Ini juga masalah saya menggunakan java-7-openjdk. - Captain Giraffe
Anda baru saja menyelamatkan saya banyak frustrasi. Terima kasih banyak. - Aniruddha
Ini bekerja saat ini untuk NetBeans IDE Dev dan Java: 1.8.0_91. Terima kasih @binary. - mixer