Pertanyaan sudo apt-get upgrade gagal karena kesalahan bersama-mime-info.postinst


Di server saya, saya mendapatkan masalah sebagai berikut. sudo apt-get pembaruan berhasil bekerja tetapi sudo apt-get upgrade gagal dengan kesalahan berikut. Tolong bantu saya untuk mengatasi masalah ini.

administrator@myserver:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  firefox linux-headers-server linux-image-server linux-server
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
21 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up shared-mime-info (0.71-1ubuntu2) ...
/var/lib/dpkg/info/shared-mime-info.postinst: line 13: 17650 Segmentation fault      update-mime-database.real /usr/share/mime
dpkg: error processing shared-mime-info (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of libgtk2.0-0:
 libgtk2.0-0 depends on shared-mime-info; however:
  Package shared-mime-info is not configured yet.
dpkg: error processing libgtk2.0-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-browser:
 chromium-browser depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing chromium-browser (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-codecs-ffmpeg:
 chromium-codecs-ffmpeg depends on chromium-browser (>= 4.0.203.0~); however:
  Package chromium-browser is not configured yet.
dpkg: error processing chromium-codecs-ffmpeg (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-browser-l10n:
 chromium-browser-l10n depends on chromium-browser (= 16.0.912.77~r118311-0ubuntu0.10.04.1)No apport report written because the error message indicates its a followup error from a previous failure.
             No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                       No apport report written because MaxReports is reached already
                                                                                                                                                                                     No apport report written because MaxReports is reached already
                                                           No apport report written because MaxReports is reached already
                                                                                                                         No apport report written because MaxReports is reached already
                                                                                                                                                                                       No apport report written because MaxReports is reached already
                                                             No apport report written because MaxReports is reached already
                                                                                                                           No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
                                                               No apport report written because MaxReports is reached already
                                                                                                                             No apport report written because MaxReports is reached already
   No apport report written because MaxReports is reached already
                                                                 ; however:
  Package chromium-browser is not configured yet.
dpkg: error processing chromium-browser-l10n (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libevdocument2:
 libevdocument2 depends on libgtk2.0-0 (>= 2.14.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libevdocument2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libevview2:
 libevview2 depends on libevdocument2 (>= 2.29.5); however:
  Package libevdocument2 is not configured yet.
 libevview2 depends on libgtk2.0-0 (>= 2.20.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libevview2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evince:
 evince depends on libevdocument2 (>= 2.29.5); however:
  Package libevdocument2 is not configured yet.
 evince depends on libevview2 (>= 2.29.5)No apport report written because MaxReports is reached already
                                                                                                       ; however:
  Package libevview2 is not configured yet.
 evince depends on libgtk2.0-0 (>= 2.16.0); however:
  Package libgtk2.0-0 is not configured yet.
 evince depends on shared-mime-info; however:
  Package shared-mime-info is not configured yet.
dpkg: error processing evince (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcalctool:
 gcalctool depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gcalctool (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgdict-1.0-6:
 libgdict-1.0-6 depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgdict-1.0-6 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-utils:
 gnome-utils depends on libgdict-1.0-6 (>= 2.23.90); however:
  Package libgdict-1.0-6 is not configured yet.
 gnome-utils depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gnome-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtk2-engines-pixbuf:
 gtk2-engines-pixbuf depends on gtk2.0-binver-2.10.0; however:
  Package gtk2.0-binver-2.10.0 is not installed.
  Package libgtk2.0-0 which provides gtk2.0-binver-2.10.0 is not configured yet.
 gtk2-engines-pixbuf depends on libgtk2.0-0 (= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gtk2-engines-pixbuf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgail18:
 libgail18 depends on libgtk2.0-0 (= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgail18 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk2.0-bin:
 libgtk2.0-bin depends on libgtk2.0-0 (>= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgtk2.0-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pidgin:
 pidgin depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing pidgin (--configure):
 dependency problems - leaving unconfigured
Setting up update-manager (1:0.134.11.1) ...
dpkg: error processing update-manager (--configure):
 subprocess installed post-installation script returned error exit status 245
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on libgtk2.0-0 (>= 2.14.0); however:
  Package libgtk2.0-0 is not configured yet.
 update-notifier depends on update-manager; however:
  Package update-manager is not configured yet.
dpkg: error processing update-notifier (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of xulrunner-1.9.2:
 xulrunner-1.9.2 depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing xulrunner-1.9.2 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of icedtea6-plugin:
 icedtea6-plugin depends on xulrunner-1.9.2; however:
  Package xulrunner-1.9.2 is not configured yet.
 icedtea6-plugin depends on libgtk2.0-0 (>= 2.8.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing icedtea6-plugin (--configure):
 dependency problems - leaving unconfigured
Setting up libgweather-common (2.30.0-0ubuntu1.1) ...
No apport report written because MaxReports is reached already
                                                              dpkg: error processing libgweather-common (--configure):
 subprocess installed post-installation script returned error exit status 245
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgweather1:
 libgweather1 depends on libgtk2.0-0 (>= 2.11.0); however:
  Package libgtk2.0-0 is not configured yet.
 libgweather1 depends on libgweather-common (>= 2.24.0); however:
  Package libgweather-common is not configured yet.
dpkg: error processing libgweather1 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 shared-mime-info
 libgtk2.0-0
 chromium-browser
 chromium-codecs-ffmpeg
 chromium-browser-l10n
 libevdocument2
 libevview2
 evince
 gcalctool
 libgdict-1.0-6
 gnome-utils
 gtk2-engines-pixbuf
 libgail18
 libgtk2.0-bin
 pidgin
 update-manager
 update-notifier
 xulrunner-1.9.2
 icedtea6-plugin
 libgweather-common
 libgweather1
E: Sub-process /usr/bin/dpkg returned an error code (1)
administrator@myserver:~$ 

Terima kasih, Avin


10
2018-02-08 09:22


asal


Anda /var/lib/dpkg/info/shared-mime-info.postinst mungkin rusak. Bisakah Anda memposting isinya? - Richard Ayotte


Jawaban:


Jika solusi "dist-upgrade" tidak berfungsi, coba instal ulang paksa dari paket shared-mime-info:

sudo apt-get update
sudo dpkg -P --force-all shared-mime-info
sudo apt-get install shared-mime-info
sudo apt-get -f install
sudo apt-get dist-upgrade
  • Jika gagal lagi, saya memerlukan keluaran penuh dari perintah di atas. Jika terlalu besar, gunakan http://www.pastebin.com dan bagikan tautan di sini.
  • Saya juga membutuhkan output dari:

    apt-cache policy shared-mime-info
    sudo gdb update-mime-database.real -ex 'r /usr/share/mime'
    

Sesuatu memberitahu saya bahwa Anda menderita bug ini: https://bugs.launchpad.net/ubuntu/+source/libxml2/+bug/759525


6
2018-02-08 09:42



Terima kasih atas balasannya ... Silakan Periksa keluaran di pastebin pastebin.com/HNEnaedU - Avin Tokade
Coba hapus cache: sudo rm -fv /usr/share/mime/mime.cache ~/.local/share/mime/mime.cache; sudo update-mime-database /usr/share/mime - Apakah Anda mendapatkan kesalahan segmentasi lagi? - Savvas Radevic
Ya, saya mendapatkan kesalahan Segmentasi administrator kesalahan @ myserver: ~ $ sudo update-mime-database / usr / share / mime [sudo] kata sandi untuk administrator: Segmentasi kesalahan - Avin Tokade
Mencoba sudo gdb update-mime-database.real -ex 'r /usr/share/mime' - tempelkan hasilnya di www.pastebin.com lagi. Saya akan memulai karunia untuk pertanyaan ini. - Savvas Radevic


Coba lakukan sudo apt-get update && sudo apt-get dist-upgrade jika kesalahan tampilan ini masih membuka synaptic> edit> perbaiki paket yang rusak dan baca ulang semua pembaruan.


3
2018-02-08 09:30



Tidak berhasil .. Silakan periksa output perintah pastebin.com/HNEnaed - Avin Tokade


Masalah ini terlihat sangat mirip dengan ini Pertanyaan StackOverflow karena ada kesalahan segmentasi untuk paket yang sama shared-mime-info

Solusinya dimakamkan di komentar sebelum dihidupkan kembali ke pertanyaan (!) - unduh maverick libxml2 paket dan instal ini sebelum menjalankan:

sudo apt-get update && sudo apt-get upgrade

Unduh file .deb sesuai dengan arsitektur Anda (32bit adalah i386 dan 64bt adalah amd64)

Instal paket melalui sintaks:

sudo dpkg -i [foo].deb

di mana [foo] adalah nama file paket yang diunduh.

misalnya menggunakan sesuatu seperti:

sudo dpkg -i libxml2_2.7.7.dfsg-4ubuntu0.3_i386.deb

3
2018-02-13 14:48





Saya tahu ini sudah tua tapi saya mendapat kesalahan dan saya memperbaikinya. Saya menggunakan Aptitude untuk melakukan itu.

Pertama pergi dan minta Aptitude untuk menghapus keduanya shared-mime-info dan libxml2

sudo aptitude menghapus shared-mime-info libxml2

Kemudian Aptitude akan memberi tahu Anda bahwa itu akan menghapus banyak paket yang dibutuhkan sistem:

Terima solusi ini? [Y / n / q /?]

Anda harus menjawab No n. Ini akan memberi Anda solusi lain

Tindakan berikut akan menyelesaikan dependensi ini:

 Install the following packages: 1)     shared-mime-info:i386 [1.0-0ubuntu4.1 (precise-updates)]

 Keep the following packages at their current version: 2)    libxml2 [2.7.8.dfsg-5.1ubuntu4.13 (now, precise-security, precise-updates)]

Terima solusi ini? [Y / n / q /?]

Untuk ini, orang mengatakan ya. Kemudian, akan menginstal versi yang tepat.

sudo apt-get pembaruan

sudo apt-get upgrade

Ini bekerja dengan sempurna untuk saya. Semoga berhasil.


2
2017-12-21 09:48