Pertanyaan Bagaimana cara menginstal beberapa versi LibreOffice?


Karena masalah yang dilaporkan sini, mungkin sebuah bug, Saya harus menggunakan LibreOffice 3.5.

Tetapi saya ingin mengawasi versi terbaru, yang mungkin bisa memecahkan masalah itu.

Saya ingin menggunakan versi 4.x terbaru selain 3.5. (tidak dalam kotak virtual atau anggur)


Yaitu: Saya sudah menginstal 3,5 dari paket deb. Bagaimana menginstal sekarang versi 4.x tanpa konflik? Saya membayangkan saya bisa menghapus 3.5 dan meletakkan 4.0 di tempat dan kemudian mencoba menginstal 3,5 secara terpisah. Tapi bagaimana caranya?


10
2018-06-10 11:43


asal


Tutorial ini harus memandu Anda melalui proses. - Glutanimate
@cipricus Maaf, tidak punya waktu sekarang, tetapi saya mungkin akan memeriksanya nanti. Sementara itu bagi siapa saja yang telah melakukan ini sebelumnya: jangan ragu untuk mengkompilasi jawaban Anda sendiri berdasarkan tutorial. - Glutanimate
@hmayag - terima kasih. sekarang mari kita hapus komentar kita - cipricus
@Glutanimate - saya sendiri membuat jawaban dengan solusi Anda - cipricus


Jawaban:


Ini didasarkan pada tutorial ini, direkomendasikan oleh Glutanimate dalam komentar untuk pertanyaan untuk membuat instalasi 'lokal' dari versi tertentu.

Saya hanya akan mempertimbangkan kasus paket file deb (ada beberapa file yang diarsipkan dalam paket).

  • Untuk mendapatkan versi terbaru sini.

  • Untuk mendapatkan versi lain pergi sini. (Saya menemukan alamat ini dari sini.)

  • Buka arsip. Anda akan mendapatkan folder, dan di dalamnya yang lain disebut 'DEBS' dengan banyak file deb.

  • Buat folder bernama 'install' (nama opsional) di dalam folder 'DEBS'.

  • Buka jendela terminal di dalam folder 'instal'. Di terminal itu, jalankan:

for i in ../*.deb; do dpkg-deb -x $i . ; done

Folder baru bernama "opt" dengan demikian dibuat di sana dengan beberapa folder dan file lain yang berisi seluruh penginstalan LibreOffice.

Jika Anda tidak ingin konfigurasi LO yang ada terpengaruh oleh instalasi paralel, Anda harus mengubah lokasi profil pengguna dari instalasi baru.

Untuk melakukannya membuka bootstraprc file berada di ./install/opt/libreoffice/program/ dalam editor teks. Anda mungkin harus mengubah hak akses file terlebih dahulu agar dapat membaca dan menulis ke file (klik kanan pada file → Properties → Permissions). Kemudian ubah UserInstallation entri ke:

UserInstallation=$ORIGIN/..

Untuk menjalankan Writer menemukan dan mengeksekusi sesuatu seperti DEBS/install/opt/libreoffice4.0/program/swriter. Yang lain (sdraw, smath, skalar, simpanan dll) berada di direktori yang sama.


Dengan cara ini, beberapa versi LibreOffice dapat digunakan secara paralel, bahkan dibuka pada saat yang bersamaan.


9
2018-06-10 15:43



Kerja bagus untuk jawabannya! Saya menambahkan sebuah bagian kecil untuk memisahkan profil pengguna dari dua instalasi untuk mencegah salah satu dari yang merusak yang lain. - Glutanimate
@Glutanimate: hebat! menurut Anda saya dapat mencoba menggunakan OpenOffice dengan cara yang sama? saya sudah pertanyaan saya yang lebih besar lainnya, yang bahkan saya posting silang sini. pada ask.libreoffice saya menemukan masalah serupa yang dilaporkan sini dan komentar yang mengatakan bahwa di OpenOffice masalah tidak ada. - cipricus
Saya kira begitu. Belum mencobanya sendiri tetapi jika Anda melihat petunjuk untuk OpenOffice Anda akan melihat bahwa mereka sangat mirip dengan LO. - Glutanimate
@Glutanimate - memang, prosedurnya identik untuk OO - cipricus
Wow! Itu mudah. Saya terkesan. - Adobe


Untuk itu untuk bekerja saya sarankan Anda kompilasi dengan tangan. Dengan begitu Anda bisa menggunakan stabil Versi 3.5 dan pendarahan 4.x versi. Jadi Anda menginstal versi stabil dengan menggunakan apt dan yang baru menggunakan repo.

Lihatlah ini panduan.

Pastikan untuk checkout yang benar menandai dari libreoffice-core untuk versi yang ingin Anda buat.

Penting untuk menambahkan --prefix=<some-folder> argumen untuk autogen.sh perintah, untuk mencegah konflik dengan instalasi saat ini. Sebagai contoh :

./autogen.sh --prefix=/home/username/my_progs

Semoga berhasil!


1
2018-06-10 12:06





Itu tidak terlihat seperti paket-paket LibreOffice yang secara native mendukung beberapa versi yang diinstal secara bersamaan. Ini mungkin terdengar seperti berlebihan, tetapi opsi yang paling sederhana, paling mungkin dipelihara adalah mungkin untuk menginstal versi 4.x di dalam sistem guest Ubuntu VirtualBox. Dengan cara itu Anda akan memiliki akses ke kedua versi tanpa harus khawatir tentang kompilasi dan kompilasi ulang ketika versi 4.x baru dirilis.


0
2018-06-10 12:14



kotak virtual bukan merupakan pilihan. saya tidak pernah menggunakannya, dan tidak mudah bagi saya. juga, perlu lebih banyak sumber daya dll, saya perlu jawaban umum independen dari variabel tersebut - cipricus
Anda harus menambahkan bahwa Anda tidak ingin menggunakan virtualisasi untuk pertanyaan karena itu akan menjadi cara yang bersih untuk melakukan sesuatu. Meskipun pointer Glutaminate ke tutorial harus melakukan trik :)
@ vasa1 - telah menambahkan itu. kotak virtual (atau anggur) adalah cara mengawasi versi terbaru: tetapi Anda lihat, saya harus menggunakan 3,5 untuk saat ini, dan saya tidak yakin 4.x akan berperilaku dalam instalasi normal karena mungkin dalam virtual kotak atau anggur. - cipricus
Orang-orang LibreOffice sebenarnya merekomendasikan masih menggunakan 3.5.x untuk keperluan produksi tetapi mereka menginginkan "sisa dari kita" untuk menguji yang terbaru dan terbaik. BTW, OT, apakah Anda memiliki ikon LibreOffice di / usr / share / icons / hicolor / scalable / mimetypes /? Pada instalasi saya dari LibO 4, saya menemukan beberapa ikon besar tersebar di seluruh tempat.
@ vasa1 :) sebenarnya saya tidak memerlukan versi yang lebih baru dari 3.5, saya hanya ingin tahu apakah masalah gulir saya (dianggap oleh komentator di bugzilla sebagai bug vga driver, bukan bug libreoffice, dan ketiadaannya di 3.5 dan sebelumnya sebagai "keberuntungan murni") akan hilang dalam versi terbaru. mudah untuk membayangkan bahwa jumlah usaha yang saya siap untuk berinvestasi karena rasa ingin tahu terbatas. mempertimbangkan mimetypes: saya menggunakan 3,5 sekarang dan akan segera menjawab - cipricus


Wiki Yayasan Dokumen berisi halaman bantuan khusus untuk menginstal beberapa versi LibreOffice:

  • lihat instruksi khusus untuk Sistem Linux (termasuk berbasis Debian, yaitu Ubuntu);
  • atau halaman generik, yang mencakup tautan ke petunjuk terperinci untuk Windows, OSX, dan Linux.

Saya mengerti bahwa jawaban "hanya-tautan" dikerutkan, tetapi lebih baik untuk menunjuk pada dokumentasi itu (yang akan disegarkan), daripada memberikan salinan / sisipan yang meragukan di sini (yang dapat dengan mudah menjadi basi).


0
2018-05-01 11:50