Pertanyaan "Tidak dapat mengambil beberapa arsip" ketika mencoba menginstal phpmyadmin


Err http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main mysql-common all 5.5.34-0ubuntu0.12.04.1
  404  Not Found [IP: 194.169.254.10 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-common all 5.5.34-0ubuntu0.12.04.1
  404  Not Found [IP: 91.189.91.15 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main libmysqlclient18 i386 5.5.34-0ubuntu0.12.04.1
  404  Not Found [IP: 91.189.91.15 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-client-core-5.5 i386 5.5.34-0ubuntu0.12.04.1
  404  Not Found [IP: 91.189.91.15 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-client-5.5 i386 5.5.34-0ubuntu0.12.04.1
  404  Not Found [IP: 91.189.91.15 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-client all 5.5.34-0ubuntu0.12.04.1
  404  Not Found [IP: 91.189.91.15 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.34-0ubuntu0.12.04.1_all.deb  404  Not Found [IP: 91.189.91.15 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.34-0ubuntu0.12.04.1_i386.deb  404  Not Found [IP: 91.189.91.15 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-core-5.5_5.5.34-0ubuntu0.12.04.1_i386.deb  404  Not Found [IP: 91.189.91.15 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-5.5_5.5.34-0ubuntu0.12.04.1_i386.deb  404  Not Found [IP: 91.189.91.15 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client_5.5.34-0ubuntu0.12.04.1_all.deb  404  Not Found [IP: 91.189.91.15 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Saya mencoba menginstal phpmyadmin di kotak virtual oracle VM menggunakan perintah sudo apt-get install phpmyadmin, ini adalah satu-satunya paket (sejauh ini) yang telah memberi saya masalah, ini juga pertama kalinya saya menjalankan perangkat lunak oracle di Windows, ide apa saja?


9
2018-02-05 20:35


asal


File '/etc/apt/source.list' saya tidak memiliki baris yang berisi 'security.ubuntu.com/ubuntu/ '; . Apa yang harus saya lakukan? Apa yang disarankan oleh garis itu?


Jawaban:


Coba gunakan

sudo apt-get update

lalu coba lagi.


16
2018-02-05 20:41





Jika sudo apt-get update juga tidak berfungsi maka ikuti langkah-langkah di bawah ini: -

  1. Buka /etc/apt/sources.list mengajukan.
  2. Periksa kata setelahnya http://security.ubuntu.com/ubuntu/ dalam sources.list file, biarkan kata menjadi xyz
  3. Pergi ke alamat http://security.ubuntu.com/ubuntu/ dan kemudian klik pada dist. Sekarang periksa apakah xyz hadir di jalan ini. Jika tidak ada, ganti xyz dengan elemen yang ada di 'dist' seperti: - cakep, jernih, tepercaya, dll.
  4. Sekarang jalankan sudo apt-get update perintah.

8
2017-07-21 12:44



+1. Satu catatan meskipun: jika ini terjadi, itu berarti bahwa linux Anda tidak lagi didukung, dalam hal ini mungkin masuk akal untuk beralih ke versi yang lebih baru. - ntg
ini memang respon yang lebih baik daripada yang diterima. Lihat komentar ntg tho - Dredok


Ada perintah untuk mengarahkan url sumber di rilis olds.

sebuah penjelasan goog dalam github gist ini:

https://gist.github.com/dergachev/f5da514802fcbbb441a1


1
2018-02-20 12:39



Anda tidak perlu pergi ke Github untuk itu, kami memiliki satu di sini: askubuntu.com/q/91815/158442. Meski begitu, ini tidak berlaku di sini, karena OP menggunakan 12.04 dan 12.04 masih didukung. - muru


Coba ubah ke server utama di bawah perangkat lunak dan pembaruan dalam pengaturan sistem. Kemudian gunakan sudo apt-get update dan kemudian coba instal. Saya memiliki masalah yang sama ketika menginstal manajer paket sinaptik.


0
2017-08-05 03:46



Sebelum Anda mencoba mengubah ke server utama, kunjungi URL yang memberikan 404 Not Found pesan di browser web untuk memeriksa apakah sudah mati. - karel


Coba ubah http://security.ubuntu.com/ubuntu untuk http://old-releases.ubuntu.com/ubuntu di /etc/apt/sources.list, lalu lari apt-get update 

(Anda dapat memeriksa apakah distro tertentu ada di sana dengan mengakses http://old-releases.ubuntu.com/ubuntu/ di browser Anda dan kemudian pilih / dist, tetapi jika tidak di security.ubuntu.com, itu harus di rilis lama


0
2018-02-16 15:32