Pertanyaan Asosiasi aplikasi Firefox tidak berfungsi di jendela 'Unduhan'


Tidak peduli apa pun perubahan yang saya lakukan terhadap asosiasi file (tindakan) di tab 'Aplikasi' di Firefox, mereka benar-benar diabaikan.
Misalnya, saya mengatur .wmv dan .avi file untuk dibuka dengan 'smplayer' tetapi ketika saya mengunduh file dan mengklik dua kali di atasnya (melalui jendela 'Downloads'), itu terus membuka dengan pemain Totem.

Asosiasi file default melalui nautilus ('buka dengan' tab) berfungsi dengan baik, yaitu saya telah mengatur smplayer sebagai pemutar default dan ketika saya mengklik dua kali file video terbuka dengan benar.

Saya sudah mencoba menghapus dan membuat ulang mimetypes.rdf tetapi itu tidak membantu.

Ada gagasan tentang apa lagi yang harus saya periksa?


9
2018-01-04 15:18


asal




Jawaban:


MEMPERBARUI: Sejak Firefox 18, Firefox memiliki dukungan GIO, bukan dukungan GnomeVFS, jadi solusi di bawah ini tidak perlu lagi. Jika ada yang masih menabrak masalah ini di versi Firefox terbaru, ini tidak akan memperbaikinya.

Jadi, ambil sisa posting ini dengan butiran garam ...

Memperbaiki

Ini memperbaikinya untuk saya:

cd .local/share/applications/
ln -s mimeapps.list defaults.list

dan akhirnya, restart Firefox. Ketika muncul lagi, Pengatur Unduhannya harus menjalankan program yang benar (sebagaimana ditentukan dalam file .list yang dirujuk di atas).

Detail

Firefox (melalui nightlies trunk pada pos ini) saat ini menggunakan API GnomeVFS untuk menanyakan "Aplikasi apa yang harus saya gunakan untuk membuka file dengan mimetype ini?" Namun, GnomeVFS sudah tidak lagi mendukung GIO.

Nautilus (Saya mencari di ver 2.32.2.1) sekarang menggunakan GIO untuk mendaftarkan aplikasi standar handler yang ditentukan pengguna (seperti smplayer dalam kasus Anda). GIO dan GnomeVFS menggunakan file yang berbeda untuk mengelola pengaturannya, tetapi file-filenya rupanya dalam format yang sama (setidaknya cukup mirip untuk di atas)ln"meretas bekerja untukku. :))

(Saya telah menyelidiki ini dengan sedikit lebih detail tentang a Laporan bug Mozilla.)


10
2017-07-31 01:19



Setelah menggali lebih dalam: Saya menemukan bahwa Firefox memiliki pilihan Dukungan GIO ditambahkan dalam bug 402892, tetapi saat ini dinonaktifkan pada waktu-bangun, secara default. Jika Anda mengkompilasi Firefox Anda sendiri, Anda bisa mengaktifkannya dengan flag build "moosconfig" --enable-gio ". - dholbert
Dalam kasus saya, defaults.list tampaknya baik-baik saja dan mimeapps.list tampaknya memiliki beberapa 'entri buruk'. Namun demikian, jawaban Anda banyak membantu. Terima kasih :-) - Pavlos G.


Untuk menindaklanjuti solusi Peterling, itu berhasil bagi saya. Saya bermain-main dengan file tipe mime saya selamanya mencoba untuk mencari tahu. Ternyata menginstal Nautilus pada sistem KDE Mint17 saya adalah cara untuk pergi. Ini mengejutkan saya karena sangat berbelit-belit bahwa Firefox sedang melihat pengaturan Nautilus pada sistem yang bahkan tidak memilikinya, tetapi di sana Anda pergi. Saya menjalankan Firefox 33 BTW.


1
2017-11-09 05:45





Anehnya, topik ini tampaknya masih aktual pada 2018.

Beberapa aplikasi yang baru saja dipasang mengambil alih status "default" di FF about:preferences bukannya aplikasi normal per-filetype yang ditetapkan pada tingkat sistem (misalnya Palemoon mengambil alih sebagai default daripada gwenview untuk file jpeg, Inskape atau File Roller mengambil alih alih-alih Okular untuk file pdf.).

"Selalu bertanya" adalah pilihan yang harus digunakan dalam kasus ini dan kemudian mencoba membuat file per-pengguna ~/.local/share/applications/mimeinfo.cache dengan garis:

[MIME Cache]
application/pdf=okularApplication_pdf.desktop

Kerugian di atas adalah bahwa itu adalah pengaturan per-file-type. Untuk memiliki solusi untuk semua file (seperti yang disebutkan di ini jawab), jalankan:

cd .local/share/applications/
ln -s mimeapps.list defaults.list

Jika ini berhenti berfungsi: lihat bahwa aplikasi yang tidak diinginkan tidak lagi dipilih di bawah about:preferences: pastikan "Selalu bertanya" dipilih di sana. Pengaturan secara manual program yang berbeda (bahkan default untuk jenis file Anda di tingkat sistem, tetapi yang tidak ditandai sebagai "default" dalam daftar untuk file Anda di bawah about:preferences) mungkin tidak berfungsi.

Diuji di Firefox 60.0 di Kubuntu 18.04.


Ada yang tidak beres dengan pengaturan Firefox. "Selalu bertanya" dan "Simpan file" tidak masuk akal untuk file yang sudah diunduh, oleh karena itu pengaturan di bawah about:preferences  seharusnya tidak mempengaruhi daftar Unduhan. Tapi mereka melakukannya. Dan mereka melakukannya dengan cara yang tidak konsisten: hanya memilih aplikasi yang ditandai sebagai default diikuti, beralih ke aplikasi lain tidak. Untuk membalikkan yang mungkin perlu memilih "Selalu bertanya" dan kemudian ikuti langkah-langkah yang disebutkan di atas.


1
2018-05-22 21:04





Tidak ada hubungannya dengan firefox. Karena file sudah diunduh. jika Anda ingin membuka unduhan .wmv dan .avi file dengan smplayer kamu bisa melakukannya seperti ini. klik kanan pada apapun .wmv file dan pilih 'Open With' --> 'Other Application...' dan pilih aplikasi favorit Anda (Dalam hal ini smplayer) dari daftar dan periksa 'Remember this application for "WMV video" files'kotak centang. lakukan hal yang sama untuk file .avi juga. alt text

Atau jika Anda ingin membuka file dari kotak dialog simpan firefox dengan aplikasi yang Anda inginkan, ikuti saja artikel ini: http://support.mozilla.com/en-US/kb/Managing%20file%20types

Semoga ini membantu


0
2018-01-04 16:12



Sayangnya, saya sudah mengatur aplikasi default melalui nautilus ke 'smplayer' dan berfungsi baik di sana. Masalahnya hanya terjadi di firefox. Adapun tautan yang Anda berikan kepada saya, saya sudah memeriksanya. Ini persis apa yang saya lakukan, tetapi itu tidak berhasil .... - Pavlos G.
Saya juga memperbarui pertanyaan saya agar sejelas mungkin. - Pavlos G.


Tab Aplikasi di preferensi Firefox mengontrol cara memutar konten yang disematkan atau ditautkan, bukan file yang diunduh. Untuk mengubah aplikasi yang membuka jenis mime tertentu melalui pengelola unduhan, tutup Firefox, lalu hapus mimeTypes.rdf file dari profil Anda, lalu buka Firefox lagi dan klik dua kali file tersebut di pengelola unduhan. Ini akan meminta aplikasi untuk digunakan. Memilih / usr / bin / smplayer, lalu centang opsi untuk mengingat pilihan Anda.


0
2018-01-04 22:48



Saya sudah mengatakan bahwa saya telah menghapus mimeTypes.rdf. Namun, tidak ada yang terjadi. Ketika saya mengklik dua kali pada file, itu hanya terbuka dengan Totem ... - Pavlos G.
Sudahkah Anda menutup Firefox sebelum menghapus mimeTypes.rdf? - lovinglinux


Saya tahu pertanyaan ini sekarang lebih dari satu tahun tetapi saya sekarang memiliki masalah yang sama dengan Firefox dan menemukan solusi setelah pertarungan panjang dengan banyak pengeditan dan perubahan.

Dan saya sangat senang tentang hal itu yang ingin saya bagikan :)

Solusinya (im my case) cukup sederhana:

Semua file yang diunduh dengan firefox dan dibuka dengan klik di jendela unduhan sepertinya akan dibuka oleh ??? cuz itu tidak ditangani dengan pengaturan firefox dan bukan dengan mimeTypes.rdf .... Ini ditangani oleh Nautilus. (walaupun saya tidak tahu mengapa)

Jadi mulailah Nautilus ... cari filetype yang tidak ditangani oleh firefox dengan benar - klik kanan padanya - properties - buka dengan -> pilih aplikasi yang Anda inginkan agar filestype ini dibuka dengan ... selesai.

Mulai sekarang Firefox akan membuka semua file dengan aplikasi yang diinginkan ketika mengkliknya di jendela unduh firefox.


0
2018-02-02 12:29