Pertanyaan Bagaimana saya dapat menonaktifkan Bluetooth pada startup sistem?


Bagaimana saya dapat menonaktifkan Bluetooth pada startup sistem?


277
2017-10-16 21:02


asal


Saya tidak berpikir bahwa "harus menjadi konfigurasi default alami", orang pasti ingin menggunakan Bluetooth di komputer mereka tanpa harus menyalakannya (Anda tampaknya tidak memiliki mouse atau keyboard Bluetooth, jika itu adalah Anda perangkat input utama yang Anda ingin Bluetooth diaktifkan dari boot). Namun saya setuju bahwa cara untuk memilih bagaimana Anda ingin Bluetooth untuk boot akan berguna untuk dimiliki. - roadmr
Hal yang normal dan alami adalah membiarkan Anda memilih, di pengaturan bluetooth, apakah Anda menginginkannya hidup atau mati ketika boot. Tidaklah wajar jika orang mematikannya atau setiap kali menyalakan komputer. Kami berbicara tentang membuat Linux menjadi sistem desktop terbaik, bukan yang terburuk, bukan? - Robert
Kami setuju bahwa membiarkan orang memilih adalah pilihan terbaik. Lihat di sini untuk beberapa kemungkinan cara melakukan ini. answers.launchpad.net/ubuntu/+source/bluez/+question/51440 - roadmr
Ini adalah bug # 1073669. - colan
Agak mengherankan bahwa, pada edisi ke-14, kami masih "mengajar" pengembang Ubuntu hal-hal seperti "opsi untuk menyalakan atau mematikan bluetooth saat boot harus tersedia untuk pengguna normal, dan tidak hanya bagi mereka yang suka mencari di garis yang tak berkesudahan forum publik ". - Rodrigo


Jawaban:


18.04+ pengguna yang tidak memiliki /etc/rc.local, Anda harus membuatnya dan membuatnya bisa dieksekusi. Agar semuanya lebih mudah, Anda tinggal menempelkan perintah berikut ke terminal:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Menjalankan sudoedit /etc/rc.local dan tambahkan ini sebelum sejalan dengan exit 0:

rfkill block bluetooth

Anda tetap dapat mengaktifkan Bluetooth melalui applet bar bagian atas.

Ini harus bekerja untuk sebagian besar sistem tetapi sepertinya ada beberapa bug yang bersembunyi di ACPI kernel untuk Thinkpads. Jika Anda menggunakan Thinkpad, tambahkan yang berikut ini /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Atau periksa ibm-acpi - Driver ThinkPad ACPI Ekstra IBM - beberapa laporan menunjukkan bahwa ibm-acpi mencakup kontrol bluetooth (di antara hal-hal menyenangkan lainnya). Tetapi saya tidak memiliki perangkat keras sehingga saya benar-benar tidak dapat memverifikasi klaim ini. Semoga berhasil.


189
2017-08-18 09:00



Untuk Thinkpads (dan hanya Thinkpads) ini berfungsi: echo disable > /proc/acpi/ibm/bluetooth di /etc/rc.local - Marius Gedminas
rfkill block bluetooth bekerja untuk Thinkpad T430u - bmaupin
Tidak bekerja untuk saya (ThinkPad x201) ketika saya menempatkannya satu per satu dalam waktu /etc/rc.local. Itu rfkill block bluetooth perintah berfungsi, tetapi tidak pada startup. Bendera -x diaktifkan /etc/rc.local. Saya menjalankan Xubuntu 13.10. - Kyle Falconer
Pada Ubuntu 15.10 dengan systemd Anda perlu lebih banyak untuk mengaktifkan kembali penggunaan etc/rc.local mengajukan: askubuntu.com/a/696226/34298 - rubo77
jika rc.local kami hanya file kosong, di mana kami harus menambahkan 'rfkill block bluetooth'? - Sss


Saya menemukan cara untuk menggunakan "solusi" bersih sini (tautan arsip untuk anak cucu)

Sebenarnya berubah /etc/bluetooth/main.conf sudah cukup bagiku.

Dari artikel:

Cari entri:

InitiallyPowered = true

dan ubah nilainya menjadi:

InitiallyPowered = false

Itu sudah cukup bagi saya, meskipun artikel itu menjelaskan beberapa langkah lain yang mungkin atau mungkin tidak diperlukan.

Di Ubuntu 17.10 dan Ubuntu 18.04 pilihan InitiallyPowered telah diganti dengan AutoEnable


70
2018-06-25 18:00



tidak berfungsi untuk laptop samsung 530u3b, bluetooth selalu hidup setelah reboot dan bangun - Maxim Kim
Ini hanya akan berhasil jika saya juga menggunakan jawaban Saeed Zarinfam tentang penempatan /etc/init.d/bluetooth stop di rc.local. Tampaknya ketika layanan dijalankan, itu juga membawa kekuatan untuk bluetooth. Saya membutuhkan keduanya untuk bekerja. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Tidak bekerja untuk saya di thinkpad t420 - UpTheCreek
"Cari entri" tidak ada gunanya bagi kita yang main.conf tidak mengandung parameter ini atau komentar apa pun yang menunjukkan lokasi default-nya. Jadi, di bawah ini [Heading] haruskah kita menaruhnya? - underscore_d
Pada kasus saya, itu adalah AutoEnable = salah, tetapi anyways +1 untuk solusi yang tepat dari tempat yang tepat. - Arman Petrosyan


Untuk menonaktifkan driver bluetooth dari memuat saat startup:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

menambahkan:

blacklist btusb

Mengaktifkannya nanti seharusnya hanya menjadi:

sudo modprobe btusb

23
2017-08-18 16:59



Terima kasih untuk itu, sepertinya berhasil tetapi saya mencoba menghindari hal-hal baris perintah sesuai dengan pertanyaan awal saya. Anda akan berpikir ini akan sesederhana seperti mencentang kotak sehingga diingat bahwa saya tidak ingin BT untuk memulai secara otomatis tetapi sepertinya cara yang lebih rumit dari itu. Dengan drive Ubuntu untuk waktu boot yang lebih cepat dan fokus umum pada konsumsi daya di laptop dan netbook, saya terkejut bahwa ini belum pernah ditangani. Saya menghargai bantuannya.
"Jalankan gedit sebagai root dan edit /etc/modprobe.d/blacklist.conf" <- ok, apakah itu baris perintah yang kurang untuk Anda? - maco
Bekerja dengan baik pada Samsung Q35 dengan Ubuntu 13.10, sedangkan pendekatan 'rfkill block bluetooth' tidak. Terima kasih! - user27164
DELL E6410 bekerja untuk saya. Bagus yang dapat berjalan lagi saat di perjalanan tanpa reset. - Ruslan Gerasimov
Jangan repot-repot mencoba "menghindari hal-hal baris perintah" saat Anda mengonfigurasi sistem operasi. Apakah Ctrl + Alt + T dan beberapa ctrl-shift-V (untuk menempel) terlalu banyak untuk ditanyakan? - doug65536


Langkah 1: Pergi ke terminal dan ketik perintah berikut untuk mengedit sistem /etc/rc.local mengajukan:

gksudo gedit /etc/rc.local

Langkah 2: Tambahkan baris berikut sebelum exit 0 garis:

rfkill block bluetooth

16
2018-05-04 20:44



Ini adalah blok lunak untuk bluetooth, saya pikir itu sama dengan mematikan layanannya dan bekerja dengan baik. - Smile.Hunter
@Robert: $ man rfkill: "Nonaktifkan perangkat yang sesuai dengan indeks yang diberikan."Terlepas dari namanya, itu hanya menonaktifkan BT; coba saja perintahnya rfkill block bluetooth di terminal, Anda akan melihat ikon menjadi abu-abu. - Daniel


Dari ubuntu 16.04 dan seterusnya, systemd mengelola layanan startup seperti bluetooth ... untuk melihat masalah status saat ini di terminal

sudo systemctl status bluetooth.service 

untuk menonaktifkan bluetooth pada masalah startup ini

sudo systemctl disable bluetooth.service

kemudian pada reboot bluetooth berikutnya tidak akan aktif ... untuk mengaktifkan masalah bluetooth

sudo systemctl enable bluetooth.service

12
2017-08-01 15:08



Ini bekerja untuk saya, tetapi sebagai efek samping, applet blueman terhenti untuk bekerja juga. Ini dimulai, tetapi tidak muncul di area indikator, jadi tidak ada cara cepat untuk mengaktifkan bluetooth, hanya di terminal. - Yuri Gor
Di Xubuntu, setidaknya, jika Anda mengklik Blueman, ia memiliki opsi "Turn Bluetooth Off". Saya pikir ini adalah apa yang OP ingin otomatis. Solusi Anda menghapus Blueman sama sekali, sehingga lebih sulit untuk mengaktifkan kembali Bluetooth jika diinginkan. - Adrian Keister
Letakkan sudo systemctl disable bluetooth.service && sudo systemctl hentikan bluetooth.service menjadi skrip Nonaktifkan, dan chmod 755 di atasnya. Lakukan hal yang sama untuk sistem sudo mengaktifkan bluetooth.service && sudo systemctl memulai bluetooth.service dalam skrip Aktifkan. - Adrian Keister


Ketik yang berikut ini ke terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

Di bagian bawah file, tambahkan baris:

blacklist bluetooth

Simpan file dan restart - Bluetooth sekarang harus dinonaktifkan.


7
2017-10-16 21:25



Ini tidak akan berfungsi pada pc saya ... - Floqqi
@Floqqi: Bisakah Anda mencobanya lagi? Saya telah memperbarui jawaban saya. - Nathan Osman
Mencoba sekitar 20 hal di thinkpad ubuntu 12 saya, ini adalah satu-satunya yang melakukan trik. - OlivierBlanvillain


Anda dapat mengubah layanan yang dimulai saat boot dengan bantuan GELANDANGAN.

Instal ini: sudo apt-get install bum

Menjalankan: sudo bum

enter image description here 

Hapus centang pada kotak dan klik Menerapkan.


7
2018-05-05 00:09



Terima kasih, desgua, aku sedang memikirkan alat semacam ini. Saya telah menggunakan beberapa di masa lalu tetapi mereka menjadi usang dan ubuntu baru, dengan obsesi minimalis mereka, datang dengan hal semacam itu. Apakah ini satu-satunya yang Anda ketahui atau yang terbaik yang Anda ketahui? - Robert
Mungkin berhasil tetapi pada awalnya itu mengecewakan saya karena mulai menunjukkan bluetooth tidak diaktifkan pada saat boot, mengapa? dan tidak berjalan ketika rfkill, applet dan hciconfig menampilkannya berjalan. Saya mematikan dan terus tetapi bum terus menunjukkan layanan sebagai off. Saya mengaktifkan layanan saat boot-up tetapi status layanan terus salah. - Robert
maaf tidak berfungsi pada elementaryOS Freya - Hoang Tran
Saya mendapatkan banyak "penggunaan nilai terinisialisasi" peringatan saat dijalankan. Maaf, tidak bisa mempercayai itu. - doug65536
Sekarang, paket itu tidak tersedia. Dikatakan, Bum itu virtual. - Satya Prakash


Saya pikir cara terbaik adalah menonaktifkan layanan dari mulai di tempat pertama. Ada metode umum untuk menonaktifkan layanan yang berfungsi sempurna:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Itu bekerja untuk Ubuntu 13.10 dan mungkin untuk versi sebelumnya juga.


5
2018-01-18 09:49



cara mengaktifkan bluetooth, saat menggunakan pengaturan yang disediakan nanti? katakanlah saya ingin menggunakannya hanya selama 5 menit. setiap 10 sepatu .. - b1r3k


saya menambahkan

"/etc/init.d/bluetooth stop"

ke

"/etc/rc.local" 

sebelum "exit 0" command untuk boot dengan bluetooth dimatikan.


5
2017-08-23 13:00



ini berhasil untuk saya, terima kasih! - woohoo
Ini menghapus ikon baki bluetooth tetapi membiarkan lampu indikator bluetooth saya menyala (menunjukkan daya masih dikirim ke radio). Sunting: ini bersama dengan jawaban Stepbaer (InitiallyPowered = false) bekerja untuk saya. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
ini tidak bekerja pada Ubuntu 14.04 dell inspiron 64-bit saya. Hanya rfkill yang bekerja untukku. - faizal