Pertanyaan Skrip PHP tidak dijalankan pada server Apache


Saya baru saja menginstal ulang Apache dan PHP5 tetapi ketika saya mengunjungi root dokumen saya, itu hanya mengunduh file "unduh". Dan ketika saya mencoba documentroot/index.php hanya mengunduh file PHP.

Saya telah menginstal PHP tetapi Apache sepertinya tidak ingin mengeksekusinya.
Orang mengatakan untuk menambahkan baris 'Load Module' ke saya httpd.conf tapi saya tidak punya file itu.


51
2018-04-20 23:46


asal




Jawaban:


Mengetik:

sudo apt-get install apache2 php5 libapache2-mod-php5

akan menginstal semua yang Anda butuhkan dan akan memulai server apache dengan dukungan untuk PHP.

Untuk memverifikasi bahwa modul php dimuat, ketik:

a2query -m php5

jika tidak diaktifkan, lalu muat dengan:

sudo a2enmod php5

dan restart apache:

sudo service apache2 restart

Pembaruan untuk php7.0, diuji pada Ubuntu 16.04 dan 16.10

Berkat komentar, saya memperbarui jawaban untuk php7.

Memasang:

sudo apt-get install apache2 php7.0 libapache2-mod-php7.0 

Memeriksa:

a2query -m php7.0

Beban:

sudo a2enmod php7.0

Mulai ulang apache:

sudo service apache2 restart

88
2018-04-21 01:02



Akan lebih baik untuk digunakan a2enmod daripada menyalin file secara manual antara mods-available dan mods-enabled. a2enmod membuat symlink dan Anda hanya akan memiliki satu salinan konfigurasi. - jkt123
@ jkt123 Anda benar. terima kasih atas sarannya, saya mengedit jawaban saya. - girardengo
Dalam kasus saya, tertulis "ERROR: modul php5 tidak ada!" sudah terpasang - Marian Klühspies
untuk ubuntu 16.04 dengan php7 saya telah menjalankan perintah-perintah ini secara berurutan apt-get install libapache2-mod-php, a2query -m php7.0, service apache2 restart - marlo
Untuk ubuntu 14.04: # a2query -m php7.0 php7.0 (diaktifkan oleh administrator situs) Masih kode php tidak dijalankan - Ashish Karpe


Penyebab umum lainnya adalah tag pendek php <? tidak diaktifkan oleh konfigurasi php.ini default, jadi setelah upgrade atau menginstal ulang, pengaturan itu dapat dimatikan dan kode php mungkin bergantung padanya. Coba ganti <? dengan <?php.

(Kredit)


17
2018-04-15 13:48





Ubuntu 16.04 telah pindah ke PHP 7. Perintah tunggal ini akan melakukan pekerjaan untuk Anda:

sudo apt-get install apache2 php libapache2-mod-php

Sini libapache2-mod-php adalah meta-paket yang menginstal libapache2-mod-php7.


8
2017-10-16 07:47





Buka php.ini dengan nano di terminal:

sudo nano /etc/php/php5.6/apache2/php.ini

Kemudian, ubah:

short_open_tag = Off

untuk

short_open_tag = On

Kemudian simpan dan kemudian restart apache2:

sudo systemctl restart apache2

2
2017-09-29 04:52



Atau perbaiki skrip PHP :-) This directive determines whether or not PHP will recognize code between <? and ?> tags as PHP source which should be processed as such. It is generally recommended that <?php and ?> should be used and that this feature should be disabled [...] - Nicolas Raoul