Pertanyaan 14.04 -> 16.04 gagal; apt (> = 1.0.1ubuntu2.13) 'tidak diinstal


(Pertanyaan ini tidak terpecahkan. Karena keterbatasan waktu Komputer dipulihkan ke pengaturan pabrik.)

Saya mencoba untuk meningkatkan dari 14.04 ke 16.04, tapi apt melemparkan kesalahan ini:

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

Apa artinya ini, dan bagaimana cara memperbaikinya?

Ketika saya mengetikkan apt-apt apt apt

Shageenth@shageenth-Inspiron-3451:~$ apt-cache policy apt apt:
Installed: 1.0.1ubuntu2.11
Candidate: 1.0.1ubuntu2.11
Version table:
*** 1.0.1ubuntu2.11 0
100 /var/lib/dpkg/status
1.0.1ubuntu2 0
500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 
Packages

Kesalahan terjadi ketika saya menjalankan perintah:

sudo do-release-upgrade -d

dan menghasilkan yang berikut:

Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,265 kB]
Fetched 1,265 kB in 0s (0 B/s)
authenticate 'xenial.tar.gz' against 'xenial.tar.gz.gpg'
extracting 'xenial.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Required depends is not installed

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

51
2018-05-24 20:45


asal


Saya telah menghapus jawaban saya sekarang karena saya telah menemukan seseorang yang dapat membantu siapa yang akan mengirim jawaban segera.
Saya juga memiliki masalah ini - mencoba untuk meningkatkan cubieboard saya (linaro port) dan tidak dapat menemukan solusi. - adib


Jawaban:


Saya punya masalah yang sama hari ini. Pastikan versi Anda adalah versi Ubuntu 14.04 terbaru sebelum peningkatan versi. (Ubuntu 14.04.4 saat ini)

Punya macet ke Ubuntu 14.04.3 karena cermin yang buruk.

Jadi, jalankan pertama:

sudo apt update
sudo apt dist-upgrade

Pastikan versinya sekarang Ubuntu 14.04.4 (pembaruan September 2016: Ubuntu 14.04.5).

cat /etc/lsb-release

Dan mulai instalasi Ubuntu 16.04 dengan

sudo do-release-upgrade -d

45
2018-05-25 06:56



Versi saya sudah 14.04 - Shageenth Sandrakumar
Versi minor (lihat .3 dan .4 setelah 14.04) adalah poin yang penting. Jika Anda sudah memiliki 14.04.4, apt dan dpkg akan menjadi versi yang tepat. - cnxsoft
Ini adalah jawaban yang benar, meskipun versinya sekarang 14.0.4.5 - Chris Ostmo
Di pengelola "Perangkat Lunak & Pembaruan", pastikan "Pembaruan keamanan penting" dan "Pembaruan yang disarankan" dicentang jika perintah dalam jawaban tidak berfungsi untuk Anda. - Patrick Brinich-Langlois
Tidak berfungsi. Jawaban lainnya. - matt


Paling baik untuk selalu memperbarui melalui prosedur normal:

sudo apt update
sudo apt dist-upgrade

Jika gagal di atas, maka Anda bisa melangkah secara manual melalui berikut ini. Pertanyaan ini sudah usang, tetapi Anda dapat mengubah nomor versi karena tautannya masih tetap sama.

Untuk meningkatkan versi Anda apt dari jendela terminal, ketik berikut ini:

sudo apt-get download apt

jika di atas tidak berfungsi, Anda juga dapat mengunduhnya wget dengan menjalankan baris berikut:

wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.17_amd64.deb

lalu ketik

sudo dpkg -i apt*.deb

Hanya mencoba ini di sistem saya di sini. Berikut hasilnya:

terrance@terrance-VirtualBox:~$ sudo apt-get download apt
[sudo] password for terrance: 
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt amd64 1.0.1ubuntu2.17 [954 kB]
Fetched 954 kB in 0s (1,127 kB/s)
terrance@terrance-VirtualBox:~$ ls
apt_1.0.1ubuntu2.17_amd64.deb  Documents  examples.desktop  Pictures  Templates
Desktop                        Downloads  Music             Public    Videos
terrance@terrance-VirtualBox:~$ sudo dpkg -i apt*.deb
(Reading database ... 168376 files and directories currently installed.)
Preparing to unpack apt_1.0.1ubuntu2.17_amd64.deb ...
Unpacking apt (1.0.1ubuntu2.17) over (1.0.1ubuntu2.11) ...
Setting up apt (1.0.1ubuntu2.17) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...

Jika Setelah langkah-langkah yang dijelaskan Anda melihat gagal karena ketergantungan dpkg yang hilang Anda bisa menyelesaikan dengan mengulangi langkah-langkah dengan dpkg dan ..

wget http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.18.24ubuntu1_amd64.deb
sudo dpkg -i dpkg_1.18.24ubuntu1_amd64.deb

Semua paket yang tersedia untuk Ubuntu dapat ditemukan di sini:

http://security.ubuntu.com/ubuntu/pool/main/


10
2018-05-24 23:02



ketika saya mengetikkan apt apt apt apt, dapatkan E: Tidak dapat menemukan sumber untuk mengunduh versi '1.0.1ubuntu2.11' dari 'apt: amd64' - Shageenth Sandrakumar
@ShageenthSandrakumar Saya memperbarui untuk wget untuk mengunduhnya secara langsung juga jika apt-get tidak berfungsi. - Terrance
@ShageenthSandrakumar Tidak sudo apt-get install dpkg kerja? - Terrance
Jika Anda mencari versi ARM (Linaro) - http://ports.ubuntu.com/ubuntu-ports/pool/main/a/apt/apt_1.0.1ubuntu2.13_armhf.deb - adib
Ini datang untukku. wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.13_amd64.deb   sekarang harus 2,17 bukan 2,13 - std''OrgnlDave


Perbaikan sederhana ... Yang berhasil bagi saya ...

Buka Synaptic Package manager Anda ketik "apt" di kotak pencarian yang akan menampilkan versi apt yang sudah diinstal memungkinkan mari kita asumsikan "1.0.1ubuntu1.13" klik kanan di atasnya dan klik tandai untuk upgrade kemudian klik tombol apply di bagian atas.

setelah upgrade ..

Pastikan untuk menutup manajer paket sinaptik sebelum menjalankannya

perintah terakhir

sudo do-release-upgrade  

dan seharusnya berhasil ..


0
2017-09-06 10:49