Pertanyaan Bagaimana cara menonaktifkan GDM dan Pilihan Pengguna Grafis?


Ubuntu baru memiliki GDM yang benar-benar tidak dapat diproses. Apakah ada cara untuk menonaktifkannya?

Ini tidak diaktifkan di layanan, skrip startup GDM dihapus, dihapus dari update.rc tetapi masih dimulai.

Bagaimana cara menonaktifkan GDM dan Pilihan Pengguna Grafis?


30
2018-05-01 21:48


asal




Jawaban:


Di Ubuntu 10.04 Anda harus mengacu dokumentasi untuk Upstart yang menangani permulaan tugas dan layanan selama boot, menghentikannya selama shutdown dan mengawasi mereka saat sistem sedang berjalan.

Mulai baru mulai gdm, jadi Anda harus mengedit /etc/init/gdm.conf

sudo vi /etc/init/gdm.conf    # or use nano if vi is unfamiliar

Runlevel default di ubuntu 10.04 adalah 2 jadi Anda harus mengubah baris ini

stop on runlevel [016]

menambahkan "2" di daftar runlevel

berhenti di runlevel [0126]

Sekarang Anda dapat mereboot sistem.


22
2017-07-18 14:43





Melakukan:

sudo dpkg-divert  --rename --add /etc/init/gdm.conf

Cetakan mana:

Adding `local diversion of /etc/init/gdm.conf to /etc/init/gdm.conf.distrib'

Ini akan memungkinkan Anda untuk menonaktifkan GDM sambil mencegah peningkatan paket dari meletakkan file kembali pada tempatnya dan memungkinkan paket GDM untuk memutakhirkan file konfigurasi.

Dalam kasus 11.x dan di atas lightdm digunakan sebagai pengganti GDM. Saya malah menggunakan perintah:

sudo dpkg-divert --rename --add /etc/init/lightdm.conf

Untuk membatalkan, ganti nama dan tambahkan dengan hapus.


15
2018-02-08 15:00





Versi Ubuntu terbaru sedang digunakan pemula bukannya SysV init.

Ganti nama /etc/init/gdm.conf untuk /etc/init/gdm.disabled.

Untuk Kubuntu, ganti nama /etc/init/kdm.conf untuk /etc/init/kdm.disabled.


12
2018-05-03 01:30





saya menemukan utas forum ini sangat membantu:

Solusi yang saya temukan yang bekerja secara konsisten adalah pos 30 oleh iscatel:

baik, ini menonaktifkan suara, seperti posting sebelumnya menunjukkan, tetapi di sini berjalan:

di /etc/default/grub, komentar (dengan menempatkan # di awal baris)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

dan tambahkan

GRUB_CMDLINE_LINUX_DEFAULT="text"

kemudian

sudo update-grub2

ini akan meneruskan "teks" ke kernel pada saat boot   baris, menonaktifkan gdm.

jika masih tidak berhasil, Anda bisa

echo "manual" > /etc/init/gdm.override

dan coba lagi. Saya menggunakan Ubuntu 12.04 server 32-bit dengan inti GNOME dan itu bekerja untuk saya.


11
2018-05-28 23:14



Baru saja mencoba, bekerja dengan baik untuk saya. Terima kasih. - Annika Backstrom


Ikuti petunjuk dari @freedev pada Kesalahan Server:

$ sudo nano /etc/init/gdm.conf

Dan ubah ke:

stop on runlevel [0126]

Juga

$ sudo nano /etc/init/tty1.conf

Dan ubah ke:

stop on runlevel [!345]

Perhatikan 2 yang hilang di tty1.conf. Ini agar Anda dapat menjalankan dan menjalankan tty1 dan dapat masuk ke konsol pertama. Tidak perlu dipusingkan dengan GRUB.


4
2018-05-08 04:04



Ini bukan forum berulir, jadi instruksi Anda untuk "mengikuti petunjuk di atas" tidak masuk akal. Bisakah Anda mengedit jawaban Anda menjadi lebih komprehensif?
@ lucian303 berhenti di runlevel [! 345] Tidak mendapatkan porsi ini File tty1.conf saya berisi: start pada stop rc RUNLEVEL = [2345] berhenti di runlevel [! 2345] jika saya berubah dari "stop on runlevel [! 2345] "to" berhenti di runlevel [! 345] "Kemudian start dan stop pada jalur akan berarti sama. Tolong jelaskan


Anda dapat beralih ke beberapa manajer tampilan lainnya (kdm atau xdm menjadi dua alternatif yang paling luas, tetapi ada banyak lagi, lihat Wikipedia). Hanya aptitude install yang ingin Anda gunakan, jalankan dpkg-reconfigure gdm dan pilih dari daftar.


2
2018-05-04 18:18





Kenapa tidak dihapus saja?

apt-get remove gdm

2
2017-11-07 09:01





Jawaban sebelumnya (pada 20160611) membahas tingkat runlevel hanya relevan untuk versi Ubuntu menggunakan Upstart. Ubuntu 16.04 beralih dari dari awal menjadi systemd. Untuk boot ke konsol, daripada X, Anda perlu mengubah target default untuk melakukan boot dari graphical untuk multi-user:

sudo systemctl enable multi-user.target --force
sudo systemctl set-default multi-user.target

Kemudian reboot. Untuk membatalkan ini:

sudo systemctl set-default graphical.target

Dan kemudian reboot.


2
2018-06-12 01:50





Bagi mereka yang datang dengan topik ini, ikuti instruksi dari freedev, tetapi bukannya berhenti gdm pada run level 2, Anda harus mencegahnya untuk memulai di runlevel 2:

Edit /etc/init/gdm.conf

$ sudo vi /etc/init/gdm.conf

Ubah baris ini

and runlevel [!06]

Dengan garis ini

and runlevel [!026]

Anda juga dapat mengecualikan level run lain (3, 4, dan 5)


1
2017-07-04 13:45