Pertanyaan Bagaimana cara memulai terminal dalam layar penuh?


Ketika saya membuka terminal menggunakan CTRL+ALT+T dalam Kesatuan, saya ingin jendela ini dimaksimalkan secara otomatis, daripada harus dipukul lagi ALT+RUANG dan tombol 'X' untuk membuat jendela yang berisi dimaksimalkan.

Jika ingatanku benar, aku ingat bahwa dulu ada memaksimalkan mode yang dapat kita atur dalam preferensi, tetapi saya tidak dapat menemukannya sekarang. Ada ide?


29
2018-05-26 14:19


asal


sudo apt-get install terminator  (terminal favorit saya). Kemudian terminator --fullscreen (Anda dapat menempatkan ini di bindings keyboard Anda jika Anda mau, dll). :) - dylnmc
terkait askubuntu.com/questions/1158/… - Ciro Santilli 新疆改造中心 六四事件 法轮功


Jawaban:


Anda dapat menggunakan Compiz Aturan Jendela plugin untuk ini.

  1. Pastikan Anda memiliki CompizConfig Settings Manager diinstal Install compizconfig-settings-manager dan jalankan.

  2. Kemudian, aktifkan Aturan Jendela plugin:

    enable window rules

    dan atur agar windows dengan kelas Gnome-terminal dicocokkan:

    enter image description here

Jika Anda menggunakan terminal yang berbeda, gunakan + tombol untuk membangun ekspresi kecocokan untuk terminal Anda.

Jika Anda ingin terminal Anda menjadi layar penuh, Anda dapat menggunakan aturan yang sesuai dalam dialog konfigurasi plugin.

Di versi Ubuntu yang lebih baru (pasti dalam 16.04) Anda harus memilikinya compiz-plugins Paket terinstal untuk mengakses Aturan Jendela.
Jika Anda tidak memilikinya, Anda perlu menginstalnya sudo apt install compiz-plugins dan reboot.


19
2018-05-26 14:28



Bagus! Hanya apa yang saya cari! Terima kasih! Namun, apakah Anda kebetulan tahu file di mana CompizConfig memodifikasi untuk mencapai ini? Mungkin saya bisa mengeditnya secara langsung daripada menginstal seluruh program hanya untuk menyelesaikan satu tugas sederhana. :) - Vern
Tidak ada aturan jendela di manajer compiz terbaru-? - umpirsky
Anda harus menginstal compiz-plugins paket (sudo apt-get install compiz-plugins). - Jacob


@Bhargav dekat dengan apa yang Anda butuhkan untuk memaksimalkan jendela - Anda hanya perlu menggunakan angka besar.

  • Buka Terminal
  • Memilih Profile Preferences dari Edit Menu.
  • Kutu Use custom default terminal size dan masukkan ukuran default terlalu besar untuk layar misalnya 240 kolom dan 100 baris.
  • Klik tutup kemudian buka Terminal baru dengan mengklik ikon ATAU menekan Ctrl + Alt + T

Jendela terminal baru harus dimaksimalkan.

Dapatkah saya menambahkan bahwa pertanyaan Anda agak tidak jelas, judul meminta layar penuh (saya menganggapnya sebagai memenuhi seluruh layar, tanpa panel atau bar kesatuan terlihat) tetapi pertanyaan sebenarnya menanyakan bagaimana hal itu dapat dimaksimalkan secara otomatis (isi desktop ruang meninggalkan panel dan bar kesatuan terlihat) yang merupakan dua permintaan berbeda dalam buku saya.

Berdasarkan saran saya diberikan di sini: Bagaimana cara membuat terminal mulai dimaksimalkan?


34
2017-07-02 14:57



Itu cara termudah untuk melakukannya IMHO. tidak bermain-main dengan Compiz, tidak perlu membuat shortcut aplikasi baru, dll. - Nikola Ivanov Nikolov
tetapi solusi ini tidak berfungsi seperti pada Ubuntu 15.10 - user907860
Bekerja hebat di 16.10 @ user907860 - Dummy


Meskipun pengguna memiliki jawaban yang diterima menggunakan Compiz, saya tidak menyukai Compiz, secara pribadi dan menginginkan cara yang "lebih bersih".

Jika Anda membuat file di ~/.local/share/applications/gnome-terminal-fullscreen.desktop.

Gunakan editor teks dan taruh ini di dalamnya:

#!/usr/bin/env xdg-open

[Desktop Entry]
Name=Terminal Fullscreen
Comment=Use the command line in fullscreen
Exec=/usr/bin/gnome-terminal --window --full-screen
Icon=utilities-terminal
Type=Application
X-GNOME-DocPath=gnome-terminal/index.html
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-terminal
X-GNOME-Bugzilla-Component=BugBuddyBugs
X-GNOME-Bugzilla-Version=3.4.1.1
Categories=GNOME;GTK;Utility;TerminalEmulator;
StartupNotify=true
OnlyShowIn=GNOME;Unity;
Keywords=Run;
Actions=New
X-Ubuntu-Gettext-Domain=gnome-terminal

[Desktop Action New]
Name=New Terminal Fullscreen
Exec=/usr/bin/gnome-terminal --window --full-screen
OnlyShowIn=Unity

Ini menempatkan aplikasi dalam hasil pencarian Aktivitas Anda memanggil Terminal Layar Penuh. Semua yang dilakukannya adalah panggilan yang sama gnome-terminal perintah tetapi dengan --window --full-screen argumen, sehingga diluncurkan dalam layar penuh. Jika Anda selalu menginginkan layar penuh, gunakan saja itu.

Semoga ini menyederhanakan sesuatu untuk seseorang.


20
2017-09-14 15:06



Layar penuh di sini mengesampingkan bilah status. Itu bukan efek yang sama seperti memaksimalkan ukuran jendela saat dibuka ... - Augustin Riedinger
Saya akan menggunakan --maximize pilihan. Lihat gnome-terminal --help-window-options. - Grzegorz Żur


Pergi ke Pengaturan Sistem -> Keyboard. Di bawah tab "Pintasan", buka "Pintasan Khusus". Buat entri baru bernama "Launch Terminal Fullscreen" (atau apa pun), dan masukkan yang berikut sebagai perintah:

gnome-terminal --window --full-screen

Anda seharusnya dapat mengklik entri itu dan kemudian menekan kombinasi tombol yang ingin Anda gunakan untuk mengatur pintasan keyboard baru, tetapi untuk beberapa alasan, itu tidak berhasil untuk saya. Jika itu yang terjadi, Anda mungkin perlu mengedit pintasan peluncur secara manual ...

Menurut halaman ini, pintasan keyboard untuk Unity dapat ditemukan di:

~/.gconf/desktop/gnome/keybindings

Setiap penautan kunci tampaknya berada di folder terpisah, bernama "custom0", "custom1", dll. Edit file "% gconf.xml" yang ditemukan di salah satu folder ini yang berisi definisi pintasan keyboard yang baru saja Anda tambahkan di "Pengaturan - > Keyboard "dialog, (jika Anda menambahkan satu). Ini milik saya, dipetakan ke "CTRL-ALT-m":

<?xml version="1.0"?>
<gconf>
<entry name="action" mtime="1381112788" type="string">
    <stringvalue>gnome-terminal --window --full-screen</stringvalue>
</entry>
<entry name="name" mtime="1381112788" type="string">
    <stringvalue>Launch Terminal Fullscreen</stringvalue>
</entry>
<entry name="binding" mtime="1381110910" type="string">
    <stringvalue>&lt;Primary&gt;&lt;Alt&gt;m</stringvalue>
</entry>
</gconf>

Saya kira Anda dapat mencoba hanya menyalin di atas menjadi file baru bernama "% gconf.xml", dan memasukkannya ke dalam folder baru bernama "customX", (di mana "X" adalah nomor yang tersedia berikutnya), di ~/.gconf/desktop/gnome/keybindingsmap. Saya belum mencoba ini.

Setelah mengedit XML dengan tangan, saya logout dan login kembali untuk memaksa scan ulang keybindings, dan voila!


5
2017-10-07 02:40





Saya menyadari ini sudah tua sekarang tetapi berpikir orang lain mungkin mengalami masalah yang sama.

Ini berhasil bagi saya. Buka terminal dan ketik:

    sudo gnome-desktop-item-edit /usr/share/applications/gnome-terminal.desktop

Lalu letakkan:

    --maximize

di kotak 'Command:', setelah 'gnome-terminal'

Anda mungkin perlu menyesuaikan pintasan keyboard Anda. Tidak ingat karena milikku semuanya sudah jadi kebiasaan.


4
2018-01-20 12:47



Ini adalah solusi terbaik. Ubuntu 15.04 tidak punya gnome-desktop-item-edit, ganti dengan itu vi sebagai gantinya. Lalu pergi ke garis yang bertuliskan Exec=gnome-terminal dan mengubahnya menjadi Exec=gnome-terminal --maximize. Selain itu, buka Keyboard di Pengaturan Sistem, dan hapus pintasan untuk terminal normal, tambahkan pintasan khusus dengan perintah gnome-terminal --maximize. Sadarilah, ini mengubahnya untuk semua pengguna. - texasflood
Komentar di atas harus menjadi jawaban yang diterima. - Dan Nissenbaum


Jika Anda menginginkan terminal layar penuh yang sesungguhnya, tekan CTRL-ALT-F#, di mana # bisa 1-6 (I.E. CTRL-ALT-F1). Untuk kembali ke Ubuntu, tekan CTRL-ALT-F7.


2
2018-05-26 17:56



Itu hanya menggunakan terminal. Apa yang saya maksudkan adalah di dalam Kesatuan dan memiliki terminal muncul di jendela di Unity :) - Vern


Goto pengaturan sistem-> keyboard-> pintas

Menekan CTRL + ALT + T di Ubuntu akan membuka jendela terminal gnome sebagai jendela mengambang biasa. Ikuti tutorial cepat ini agar jendela ini mulai dimaksimalkan atau layar penuh secara default. Hapus Peluncur Default

Temukan pengaturan keyboard dan di bawah kategori Peluncur untuk Pintasan mengubah terminal Peluncuran dari CTRL + ALT + T ke yang lain. Saya mengubah milik saya menjadi CTRL + ALT + W supaya saya dapat dengan mudah menggunakan versi berjendela asli.

Tambahkan entri pintasan kustom baru dan beri nama "Launch Terminal Fullscreen" dan masukkan yang berikut sebagai perintah.

gnome-terminal --window --maximize

Tetapkan Pintasan

Pintasan khusus baru untuk keyboard dinonaktifkan secara default. Anda perlu menetapkan kode keyboard CTRL + ALT + T untuk pintasan baru agar berfungsi.

Anda harus siap sekarang. Cobalah.

Catatan: coba keduanya - layar penuh dan --maximize lihat tautan ini untuk informasi lebih lanjut


2
2017-07-23 09:04





Anda dapat mencoba pendekatan alternatif untuk memaksimalkan.

Buka Terminal -> Edit -> Preferensi Profil, Di Tab Umum, Periksa

"Gunakan Ukuran Terminal Default Kustom"

kotak dan bermain-main dengan nilai-nilai tersebut (Baris dan Kolom).

Anda dapat mengaturnya ke ukuran apa pun yang Anda inginkan.


1
2018-05-26 14:30



Saya sudah mencoba menggunakan itu, tetapi bahkan dengan 80 x 24 di layar saya meninggalkan perbatasan yang memaksimalkan jendela tidak :) - Vern


Solusi saya mengesampingkan kunci default yang mengikat untuk terminal Run

  1. Pergi ke System> Preferences> Hardware> Keyboard Shortcuts

    (Saya menggunakan ubuntu mate, mungkin berbeda di sistem lain, intinya adalah Anda sampai ke jendela pintas Keyboard)

  2. Tambahkan pintasan kustom dengan mengklik + tombol. Isi 2 kolom input

    Nama: Apa pun yang Anda inginkan (Misalnya: Terminal dimaksimalkan)

    Perintah: mate-terminal --maximize seperti yang Anda gunakan mate terminal

    atau gnome-terminal --maximize seperti yang Anda gunakan gnome-terminal

    Kemudian Anda menambahkan pintasan sebagai Ctrl + Alt + T

    Sejak saat itu, ketika Anda menekan Ctrl + Alt + T, Anda akan mendapatkan jendela terminal yang dimaksimalkan.


1
2018-06-17 07:49