Pertanyaan Bunyi yang aneh di headphone saat tidak ada suara yang dimainkan


Ada suara aneh dari headphone saya di Lenovo T440. Suara seperti ketika Anda menyetel radio Anda, tetapi Anda mendapatkan frekuensi yang salah dan Anda mendengar suara tidak menyenangkan. Kebisingan dimulai ketika Ubuntu 14.04 melakukan booting dan berakhir setelah shutdown. Itu hanya keluar melalui headphone saya, tidak ada suara melalui speaker.

Yang aneh adalah suara itu hilang ketika ada suara yang dimainkan atau jika saya memasukkan preferensi suara. Tetapi ketika suara berhenti, itu akan muncul lagi setelah 10 detik atau kurang. Juga, kebisingan berjalan menurun (atau bahkan mungkin hilang) jika saya memasukkan charger laptop saya dan menghentikan musik.

Tidak peduli bagaimana saya mengubah level volume saya, tingkat kebisingannya sama. Sepertinya keluarannya tidak dinonaktifkan setelah suara berhenti.

sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC292 Analog [ALC292 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

29
2018-04-29 20:20


asal


im pada lenovo t440s dan masalah ini baru-baru ini terjadi dengan setup saya di 14.04 juga. karena tidak ada hubungannya seperti tampaknya, dugaan saya adalah bahwa hal itu terjadi setelah saya mengubah beberapa pengaturan / etc / x11 / mouse terkait dan kemudian restart lightdm. tidak pernah menjadi masalah di masa lalu dan sekarang yang meresap. - faith_in_facts
Masalahnya hilang setelah saya mengubah beep saluran masuk alsamixer dari 0 untuk sesuatu yang lain dan kembali ke 0 - EECOLOR
Kemungkinan duplikat dari Masalah Kebisingan lama yang buruk di headphone pada Ubuntu 16.04 LTS - Logan
membalikkan arah (memilih untuk membiarkan ini terbuka) karena posting ini memiliki lebih banyak jawaban pandangan dan suara - Zanna


Jawaban:


Punya masalah yang sama pada Dell XPS15 (9550, model 2015 di Xenial). Memecahkannya di alsamixer dan mematikan loopback saluran.

$ alsamixer

Menavigasi ke loopback (semua jalan ke kanan, dengan  key) dan pengaturannya Disabled menggunakan  kunci.

  • Tidak perlu reboot;
  • Tidak perlu root;
  • Apakah permanen sejauh yang saya perhatikan.

25
2017-08-15 16:53



Solusi ini bekerja pada Dell Precision 5510 saya. - dmiller309
Ini bekerja pada Dell Precision 5510 saya juga. Terima kasih! - L42
Ini berfungsi dengan sempurna di Dell - Maduka Jayalath
Bekerja pada Lenovo y700. Saya memiliki masalah dengan masalah kebisingan dengan speaker bukan telepon kepala. Metode hemat audio_power tidak berfungsi dalam kasus saya - alphabetagamma
Dengan metode ini, Anda juga dapat menghemat daya, dan menghemat baterai. - JonasCz


Saya memiliki masalah yang sama pada Dell Inspiron 3542 yang menjalankan Ubuntu 14.04.2

Masalahnya muncul dalam fitur hemat daya audio.

Kebisingan berhenti ketika saya membuka pengaturan suara, atau ketika saya memutar audio / video. Kebisingan mulai lagi ketika saya berhenti memainkan audio / video dan menutup pengaturan suara.

Solusi ini berhasil untuk saya: Edit file

$ sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave

mengubah garis

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

untuk

INTEL_AUDIO_POWERSAVE=false

Reboot.

Saya tidak lagi menghadapi keributan setelah ini.


12
2018-04-26 02:17



Bekerja dengan sempurna untuk saya, Xenial pada Dell XPS 13 9350 - Robin Winslow
ada ide mengapa penghematan daya menyebabkan suara-suara aneh ini? Bukankah daya menghemat barang bagus. Saya hanya penasaran! - Surya Teja Karra
sudo aplay -l memberi saya output yang sama. Saya menggunakan Dell Inspiron 15 3542. Saya tidak memiliki file "intel-audio-powersave". Bisakah saya membuatnya? - Logan
Mungkin Anda perlu memilih kartu suara yang benar dengan menggunakan F6 terlebih dahulu - Alex0007
Kamu sangat mengagumkan !!! Bekerja pada Macbook saya, 2006 Akhir berjalan hanya Ubuntu 16.04 LTS :) - yanike


Ini mungkin antarmuka audio Anda akan menghemat daya.

Jika mengikuti perintah untuk menghapus masalah sampai Anda reboot atau mengubah catu daya yang ada hubungannya dengan penghematan daya:

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller
echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save

7
2017-10-09 13:02



Terima kasih! Yang ini bekerja pada distro lain ;-) Saya akhirnya memiliki sesuatu seperti "opsi snd_hda_intel power_save = 0 power_save_controller = 0" di modprobe.conf saya ... - Lester Cheung
Bekerja dengan sempurna untuk saya, Xenial pada Dell Inspiron 14 7000 - Ren
Terus bekerja dengan 18,04 LTS (bionik). - Kyle Barbour


Saya memiliki masalah yang sama. Saya percaya itu adalah suara yang mikrofon Anda ambil.

Pergi ke Sound Settings, di bawah Input tab, periksa Mute kotak dekat Settings for <microphone_name> Microphone (Bukan Mute kotak centang di bagian atas).

enter image description here

Itu harus melakukan trik.


5
2017-10-09 12:50



Mengikuti instruksi Anda, headphone saya tidak bersuara. - Tianren Liu
Bagi saya di Dell M3800, itu tidak berpengaruh. - Garrett
mikrofon biasanya tidak diputar di speaker kecuali Anda menjalankannya pactl load-module module-loopback latency_msec=1 - mchid
Ini berhasil bagi saya. Mematikan mikrofon akan menghilangkan semua kebisingan. Terima kasih. - Hussein El Motayam
Ini berhasil. Bisakah seseorang menjelaskan mengapa ini berfungsi ?? - Parag Gangil


Saya memiliki masalah yang sama persis dan tidak ada metode di atas yang berhasil untuk saya.

Laptop saya adalah ASUS ROG-G501JW dan kartu suaranya adalah Realtek.

Saya menemukan solusinya di utas ini: Suara putih dan desisan di headphone, tidak hadir di Windows.

Menetapkan baris ini di /etc/modprobe.d/alsa-base.conf memperbaiki semua masalah saya:

options snd-hda-intel model=dell-headset-multi

3
2018-01-09 21:19





Apakah Anda sudah mengaktifkan tlp?

Jika begitu sunting / etc / default / tlp dan atur nilai opsi hemat daya ke 0

SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=0

ini melakukan trik untukku


2
2018-05-09 02:48



Di Dell M3800 saya, saya mencoba pengaturan SOUND_POWER_SAVE=0, tapi itu tidak membantu ... - Garrett


Saya punya masalah ini pada Dell 3542 dengan Ubuntu 16.04 GNOME dan itu mulai terjadi setelah saya menginstal TLP untuk menghemat daya. Jadi setelah saya melihat di sini bahwa masalahnya terkait dengan penghematan daya, saya cukup menghapus TLP dan masalah itu hilang.


0
2017-11-06 13:12





Saya memiliki masalah ini pada Asus X200ca dengan ElementaryOS Loki (Ubuntu 16.04) dan distro linux lain yang pernah saya gunakan. Saya memperbaiki masalah

  • menjalankan alsamixer (tidak dalam mode sudo)
  • Navigasi ke Auto-mute Mode (menggunakan panah kanan)
  • Ubah untuk mengaktifkan (menggunakan panah atas)

Sekarang saya tidak punya masalah lagi.


0
2018-01-23 08:08





Saya menemukan penyebab yang tidak biasa untuk kebisingan latar belakang saya yang berlebihan ... Peradaban saya 5 (dijalankan melalui Steam) tidak keluar dengan benar. Suara latar belakang yang saya dengar berasal dari permainan. Saya menggunakan "htop" untuk menemukan dan membunuh semua proses Peradaban dan cukup yakin, kebisingan menurun setiap kali saya membunuh proses dari permainan.

Jadi bukan masalah Ubuntu atau audio; itu sebenarnya satu aplikasi tertentu (yang tidak pernah keluar juga).


0
2017-11-18 21:36