Pertanyaan Bagaimana saya mencegah Skype memulai secara otomatis saat boot?


Pacar saya masuk ke akun Skype-nya dari netbook Xubuntu 12.10 saya, dan sejak itu Skype mulai secara otomatis setiap kali saya boot. Bagaimana cara mencegah hal ini terjadi?

Hal-hal yang saya coba:

  • Menghapusnya dari Settings Manager-> Session dan Startup-> Application Autostart - tidak dapat menemukannya di daftar.
  • Memeriksa pengaturan yang relevan di Skype itu sendiri - tidak dapat menemukan hal semacam itu. (Saya ingat ada pengaturan Skype serupa di suatu tempat setiap kali saya menggunakannya di Windows. Mempertimbangkan pacar saya adalah pengguna Windows, mungkinkah ini adalah pengaturan yang tersedia pada klien Windows tetapi tidak pada Linux, dan entah bagaimana dipindahkan?)
  • Menggunakan GELANDANGAN untuk mematikannya - sekali lagi, tidak dapat menemukannya di daftar.
  • Menghapus instalasi Skype dengan apt-get remove skype --purge dan berharap itu menghapus semua pengaturan juga - tidak.

Simpan untuk menginstal ulang, apa lagi yang bisa saya coba?

Sementara pada catatan yang sama - bagaimana mungkin Skype untuk autostart tanpa melalui rute Upstart yang normal?

EDIT: Beberapa hal lainnya yang saya coba:

  • Mencari sesuatu yang serupa dalam dukungan Skype - saya tidak berharap menemukan apa pun, dan saya tidak.
  • Melihat melalui .Skype folder di direktori home saya. Saya menemukan beberapa file yang tampak menjanjikan (.Skype/shared.xml, .Skype/[my username]/config.xml, .Skype/[girlfriend's username]/config.xml), tetapi melihat melalui mereka tidak menghasilkan apa-apa. Banyak file SQLite sekalipun. Mungkinkah pengaturan ini ada di suatu tempat di dalam?

27
2018-03-17 11:05


asal


Coba pergi /etc/xdg/autostart lihat apakah entri untuk Skype ada di sana, jika kemudian hapus. - Mitch♦
Tidak bisa melihatnya di sana. - Andrey
Solusi untuk 2018+ versi aku s ini. - cipricus


Jawaban:


Punya masalah yang sama dan yang berikut ini tampaknya telah menjaganya: pergi ke (Xubuntu) Pengaturan> Sesi dan Startup> Sesi, cari Skype dan klik kiri di mana ia mengatakan "Jika Menjalankan" dan ubah ke "Tidak Pernah".


23
2018-03-19 09:15



Tidak melakukan trik untukku, aku takut. - Andrey
Coba klik "Hapus sesi tersimpan" di bawah pengaturan yang sama dan pastikan "Simpan sesi logout secara otomatis" tidak dijerat di bawah "Umum". - azeam
Ah! Unticking "Secara otomatis menyimpan sesi pada logout" adalah sesuatu yang saya coba sebelumnya, tetapi saya tidak melihat tombol "Clear saved sessions". Ini berhasil, terima kasih atas bantuan Anda. - Andrey
Untuk versi 2017+, lihat jawaban lain. - int_ua


Untuk skype versi 2017 yang cukup lancang untuk menambahkan sendiri ke autostart setiap kali dimulai (serius? Jangan pernah menginstalnya di komputer saya sendiri) cukup untuk membuat folder dengan nama yang sama dengan file yang coba dibuat:

rm ~/.config/autostart/skypeforlinux.desktop
mkdir ~/.config/autostart/skypeforlinux.desktop

29
2017-11-16 12:48



Itu juga bekerja bagi saya untuk membuka file skypeforlinux.desktop dan (kembali) menyimpannya dengan X-GNOME-Autostart-enabled disetel ke false. Yaitu., X-GNOME-Autostart-enabled=false - Tom
rm: cannot remove '/home/cip/.config/autostart/skypeforlinux.desktop': No such file or directory - cipricus
@Tom - bagaimana dengan KDE? Saya tidak memiliki garis `X-GNOME-Autostart-enabled` - cipricus
Masuk dan hapus centang opsi untuk memulai dengan sistem akan menghentikan Skype dari menambahkan dirinya ke autostart setiap kali dimulai - cipricus
Terima kasih, @cipricus, mungkin tidak ada opsi seperti itu pada saat menulis. Tidak dapat memverifikasi sekarang. Apakah mengubah opsi ini mengubah skypeforlinux.desktop isi? - int_ua


Karena tampaknya jawaban di sini berubah setiap saat, seperti pemasangan skypeforlinux dari awal pekan ini (versi 8.11.0.4), saya berhasil mendapatkan autostart untuk berhenti dengan dua langkah.

Pertama, buka Skype, buka Alat> Pengaturan dan hapus centang "Otomatis mulai Skype".

enter image description here

Kemudian, terinspirasi oleh saran azeam, buka (Xubuntu) Pengaturan> Sesi dan Mulai> Mulai Otomatis Aplikasi, dan hapus item untuk Skype. Saya tidak yakin apakah batal memeriksa; Saya mencoba yang pertama, tetapi mungkin bertentangan dengan pengaturan internal Skype ketika saya mencobanya.


13
2017-12-10 17:47



Langkah pertama harus cukup (dan itu, paling tidak di Ubuntu 16.04 dengan Plasma 5.8) karena pengaturan di Skype adalah (harus) mengedit daftar autostart. - cipricus
Langkah pertama sudah cukup. Diperiksa untuk Linux Mint 18.3 Cinnamon 64-bit, versi 3.6.6. dan Skype versi 8.20.0.9. - Alex.K.
Perhatikan bahwa Anda harus masuk untuk Mengakses menu "Pengaturan". Saya tidak tahu bagaimana Anda dapat menonaktifkan start otomatis tanpa memiliki akun di Skype. Itu gila. - Clément


Saya memiliki masalah yang sama. Saya dapat mencegahnya memulai secara otomatis dengan menghapus skypeforlinux.desktop dari ~/.config/autostart/. Saya menggunakan lubuntu; lokasi folder autostart Anda dapat bervariasi. Anda dapat menemukan dengan menggunakan:

$ locate skypeforlinux.desktop

Anda benar-benar hanya ingin menghapus salinan di direktori bernama autostart, jika tidak, Anda tidak akan dapat memulai aplikasi dari ikon.

Saya berasumsi bahwa pada saat Anda sebenarnya, dengan sengaja menjalankan Skype (saya harap, demi kewarasan Anda, bahwa hari ini adalah jauh di masa depan) bahwa itu akan mencoba untuk mengembalikan file itu. Dalam hal ini Anda mungkin harus menghapusnya lagi atau menjelajahi Skype untuk pengaturan yang akan mencegah perilaku itu.


7
2017-11-01 13:44





Pergi ke Tools -> Options -> Pengaturan umum. Hapus centang opsi "Mulai Skype ketika saya mulai". Simpan dan Keluar dari Skype.


5
2018-03-17 11:23



Bukan dari klien yang saya gunakan: imgur.com/EsiEKIl - Andrey
Yah, itu tidak berhasil karena pilihannya ada di sana, tetapi tidak di alat itu kolom. Buka Privasi. - horIzoN
@ nerof61 Seperti yang saya sebutkan di pertanyaan saya di atas, saya sudah memeriksa opsi yang sudah ada. Tidak ada pengaturan tunggal yang memungkinkan saya mencegah Skype memulai saat boot. - Andrey
Itu hanya di Microsoft Windows. - John Scott


Di Kubuntu 14.04, masalah diselesaikan dengan membuka Startup dan Shutdown, kemudian Session Management dan memeriksa Mulai dengan sesi kosong dan Terapkan.


2
2018-05-05 18:07



Itu sebelum skype mulai menambahkan dirinya ke autostart setiap kali Anda menjalankannya. Saya menggunakan KDE dan tidak berfungsi. Untuk versi 2017+, periksa jawaban lain. - int_ua


Untuk Ubuntu 16.04 reguler, cari "Aplikasi Startup". Ketika jendela terbuka, cukup hapus centang dari Skype untuk mencegahnya mulai saat boot, lalu klik hapus saat Anda memilih Skype untuk menghapusnya dari daftar.


1
2018-05-20 18:55





Tampaknya kasus yang 'menutup' Skype sebenarnya tidak benar-benar menutupnya. Anda dapat melihat bahwa juga dengan fakta bahwa jika Anda 'membukanya kembali', itu sudah masuk.

Anda dapat benar-benar menutupnya dengan mengetikkan baris perintah:

killall skype

Dengan cara ini tidak akan disimpan dalam sesi kerja Anda ketika Anda log out dari komputer Anda, dan jadi tidak akan secara otomatis dikembalikan saat me-restart komputer Anda.


0
2017-08-15 22:54





Menutup Skype tidak sama dengan Berhenti Skype. Saya melakukan tiga hal dalam Kubuntu 14.04. Setelah Membuka Skype, saya pergi ke Skype (Menu)> Opsi> Umum dan memeriksa "Mulai Skype yang Diminimalkan di Baki Sistem". Kemudian Pilihan> Lanjutan dan tidak dicentang "Periksa pembaruan pada Permulaan". Akhirnya, daripada "Keluar" saya mengklik "Keluar" di bagian bawah menu. Saya percaya itu adalah langkah terakhir yang berhasil.


0
2018-03-19 00:41