Pertanyaan Bagaimana saya bisa menginstal OpenJDK di Ubuntu 16.04? [duplikat]


Pertanyaan ini sudah memiliki jawaban di sini:

Karena saya meng-upgrade ke versi terbaru Ubuntu, saya tidak dapat menginstal paket Java OpenJDK yang diperlukan untuk mengkompilasi ROM kustom Android. Ketika saya menjalankan sudo apt-get install openjdk-7-jdk, kesalahan berikut muncul:

Reading package lists... Done Building dependency tree        Reading
state information... Done Some packages could not be installed. This
may mean that you have requested an impossible situation or if you are
using the unstable distribution that some required packages have not
yet been created or been moved out of Incoming. The following
information may help to resolve the situation:

The following packages have unmet dependencies:  openjdk-7-jdk :
 Depends: openjdk-7-jre (= 7u51-2.4.6-1ubuntu4) E: Unable to correct
 problems, you have held broken packages.

Bagaimana cara memperbaiki masalah ini?


26
2018-04-20 10:57


asal


Saya baru menginstal openjdk-8-jdk dan openjdk-8-jre pada 16.04, mungkin mencobanya? - Organic Marble
Jika Anda gagal menginstal Openjdk, instal Oracle jdk dengan mengikuti instruksi yang baik di sini askubuntu.com/questions/521145/… - Alexiy
Saya kira tidak semua paket diunduh saat menginstal sistem..karena saya tidak memiliki kesalahan ini pada 14.04 .. - Hakam El Assouad
Lihat juga: askubuntu.com/questions/761127/… - MDMower


Jawaban:


memiliki masalah yang sama juga .. tetapi saya memecahkannya dengan perintah ini:

sudo add-apt-repository ppa:openjdk-r/ppa  
sudo apt-get update   
sudo apt-get install openjdk-7-jre  

56
2018-04-23 10:19



itu Pekerjaan Besar: D - Mohamed Adel


Yang saya lakukan pada 16.04 adalah:

Untuk OpenJDK 8.X

sudo apt install openjdk-8-jre

Untuk OpenJDK 9.X

sudo apt install openjdk-9-jre

Catatan: Tidak ada openjdk-6-jre maupun openjdk-7-jre bagi saya di Ubuntu 16.04. Juga TIDAK perlu menginstal Oracle JDK (Sebenarnya OpenJDK jauh lebih baik daripada Oracle untuk saya).


22
2018-04-24 01:49





Beberapa umpan balik dengan 16.04 ... Jika Anda menginstal sebagai bagian dari paket "skrip perangkat lunak", Anda harus selalu memeriksa versi Java mana yang didukung oleh program terlebih dahulu.

Misalnya, menggunakan openjdk-8-jre (versi yang lebih baru) pada skrip pemasangan.

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install openjdk-8-jre

0
2017-10-24 22:53