Pertanyaan Warna Terminal Tidak Bekerja


Saya mengakses server Ubuntu 10.04.2 LTS melalui SSH dari OSX. Baru-baru ini warna berhenti bekerja. Saya pikir itu terjadi ketika saya menginstal / troubleshooting RVM, tapi saya tidak positif.

Di .bashrc saya belum selesai force_color_prompt=yes, dan ketika saya berlari env | grep TERM saya mendapat TERM=xterm-color. Tapi tetap tidak ada warna.

Ada ide? Terima kasih!

Berikut ini adalah hasil dari cat .bashrc

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoredups:ignorespace

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi


# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac


# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
   alias dir='dir --color=auto'
   alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi

[[ -s "/usr/local/rvm/scripts/rvm" ]] && . "/usr/local/rvm/scripts/rvm"

24
2018-05-03 16:01


asal


Hai! Tambahkan output dari cat ~/.bashrc untuk pertanyaan Anda, silakan! - antivirtel


Jawaban:


Ada contoh, file .bashrc default yang terletak di / etc / skel - Anda dapat membuat cadangan dari .bashrc Anda saat ini dengan mv .bashrc .bashrc.bak lalu cp /etc/skel/.bashrc .bashrc untuk menyalin sampel itu kembali ke direktori home Anda. Setelah itu, batalkan komentar force_color_prompt=yes di file baru dan tambahkan [[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" kembali ke akhir (baris terakhir) dari file sehingga RVM masih berfungsi.

Setelah itu, laksanakan . .bashrc pada prompt untuk memuat ulang profil bash Anda, yang akan memberi Anda prompt berwarna lagi dan menguji RVM dengan perintah type rvm | head -1 yang harus mengembalikan teks: rvm is a function

Jika ini tidak berhasil, beri tahu kami jika Anda menggunakan aplikasi Terminal standar di Mac OS X, dan profil apa yang Anda gunakan di Terminal pada Mac Anda.


20
2017-09-17 01:34



Bekerja untuk saya, Xubuntu 13.04 - Green


Warna telah berhenti berfungsi, kemungkinan besar setelah Anda meningkatkan ke Singa dari Macan Tutul Salju.

Di Lion, untuk beberapa alasan, secara default terminal dinyatakan sebagai "xterm-256color" dari pada "xterm-color"Itulah yang dipahami Ubuntu.

Salah satu opsi adalah untuk Anda, seperti yang disebutkan oleh responden sebelumnya, tanda komentar force_color_prompt=yes di ~/.bashrc

Pilihan lainnya adalah redeclare di Terminal.app terminal sebagai warna xterm. Begini caranya:

  1. Luncurkan Terminal.app
  2. Pergi ke menu Terminal -> Preferences (atau gunakan Cmd +,)
  3. Pergi ke Settings tab dan temukan tema yang ditetapkan sebagai default
  4. Pergi ke Advanced tab
  5. Temukan tarik turun di samping Declare terminal as: dan mengaturnya xterm-color

Inilah saya Pengaturan

MEMPERBARUI: Tampaknya Singa gunung dihapus xterm-color pilihan sepenuhnya dari menu drop down. Jika Anda melakukan upgrade, Anda mungkin akan menyimpan konfigurasi lama Anda, tetapi jika Anda melakukan instalasi baru, Anda harus mengedit file konfigurasi Terminal secara manual dan untuk itu Anda memerlukan editor plist (termasuk dalam Xcode yang perlu dipasang melalui App Store). Lokasi file Terminal dalam ~ / Library / Preferences / com.apple.Terminal.plist untuk menambahkan xterm-color pilihan lakukan hal berikut:

  1. Berhenti Terminal.app jika itu sedang berjalan
  2. Instal Xcode dari App Store (lewati langkah ini jika Anda sudah menginstalnya)
  3. $ open ~/Library/Preferences/com.apple.Terminal.plist
  4. Arahkan jendelanya ke Root > Window Settings
  5. temukan nama tema default Anda (dalam kasus saya yang Pro) perluas dan temukan TerminalType kunci.
  6. Sekarang ganti saja TerminalType kunci untuk xterm-color secara manual
  7. simpan file dan luncurkan Terminal.

8
2017-10-23 13:20





Salah satu alternatif yang Anda miliki adalah membuat peti a .bash_login file jika tidak ada di direktori home Anda, dan masukkan .bashrcdalam.

Tutup terminal dan buka kembali - masalah Anda harus diselesaikan!


0
2017-07-22 06:31





Daripada mencoba memaksa Terminal macOS untuk melaporkan TERM sebagai warna xterm yang lebih lama, Anda dapat mengubah .bashrc Anda di Linux untuk mengenali xterm-256color sebagai klien warna. Ini tampaknya menjadi default untuk versi Ubuntu yang lebih baru. Untuk melakukan ini, ubah baris ini:

xterm-color) color_prompt=yes;;

untuk:

xterm-color|*-256color) color_prompt=yes;;

Lalu lari source .bashrc dan terminal Anda akan ditampilkan dalam warna.


0
2017-12-31 07:27