Pertanyaan Memaksa layar masuk gdm ke monitor utama


Saya memiliki dua monitor yang terpasang ke kartu video saya. Monitor utama memiliki resolusi sama dengan 1280x1024 dan yang kedua memiliki 1920x1200. Saya gdm layar login selalu muncul pada monitor kedua meskipun dimatikan. Pertanyaan saya adalah bagaimana memaksa gdm untuk menampilkan layar masuk selalu di monitor utama dengan resolusi 1280x1024?

Saya menggunakan Nvidia GT9500 videcard dalam mode Twinview. Saya tidak dapat menggunakan Xinerama karena vpdau tidak bekerja sesuai dengan mode ini.

Apa yang saya temukan adalah bahwa penunjuk mouse selalu muncul di tengah penyatuan layar dan pusat selalu di monitor dengan resolusi yang lebih tinggi. Layar login selalu menunjukkan di mana kursor mouse berada.


Sekarang monitor utama saya memiliki resolusi yang sama dengan 1920x1080. Masalahnya masih berlanjut, kursor mouse selalu muncul di sudut kanan bawah monitor kedua.


22
2017-11-06 12:26


asal




Jawaban:


Untuk versi Ubuntu yang lebih baru seperti 13.10 atau ditingkatkan 13,04 menggunakan Gnome 3.8, prosedur ini berbeda karena file konfigurasi X tidak lagi mengontrol tata letak monitor. Anda harus melakukan hal berikut:

  1. Atur tata letak monitor dengan benar sebagai pengguna yang masuk (lihat Setel monitor permanen sebagai utama)

  2. Salin file konfigurasi ke pengaturan gdm

    cp ~/.config/monitors.xml ~gdm/.config/
    

Untuk lebih jelasnya, lihat https://bbs.archlinux.org/viewtopic.php?id=161903


20
2017-09-18 18:40



Dikonfirmasi, ia bekerja untuk GNOME 3.10 juga. Lokasi absolut dari ~gdm/.config/aku s /var/lib/gdm/.config/ jika orang lain bertanya-tanya. - Forage
terlihat pada gnome 3.14: sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config/ - Francois
Saya dapat mengkonfirmasi bahwa trik sederhana ini bekerja pada Ubuntu 17.04 dengan Gnome 3.24.2 juga. Saya baru saja menjalankan perintah @Francois diposting dan sekarang berfungsi seperti pesona. - fgblomqvist
Masih berfungsi di 17.10 menggunakan Xorg. Tetapi jangan mencoba untuk menjadi pintar dan symlink konfigurasi pengguna Anda. Itu tidak akan bekerja. - raphinesse


apakah Anda menggunakan kartu Nvidia dengan pengaturan layar ganda?

Jika demikian, saya memiliki masalah yang sama, dan menyelesaikannya dengan cara berikut: Matikan komputer, cabut monitor kedua, hidupkan kembali komputer, jalankan 'sudo nvidia-settings', pasang kembali monitor kedua, jalankan 'Deteksi Menampilkan 'di Nvidia GUI, dan buat konfigurasi yang diperlukan sebelum menyimpan pengaturan. PENTING PENTING adalah layar yang Anda inginkan untuk masuk ditampilkan ke 'Nomor Layar: 0'.

Dalam kasus saya, membiarkan monitor kedua dicolokkan sebelum menjalankan 'nvidia-settings' meninggalkannya sebagai layar 0 untuk beberapa alasan, tetapi dengan menghubungkannya setelah, ini telah disortir.


1
2017-11-07 07:47



Ya, saya menggunakan kartu Nvidia dalam mode TwinView. Dalam mode ini setiap layar adalah layar 0. Jadi mencabut tidak membantu. - Kirill V. Lyadvinsky
Oke, tidak ada pengalaman dengan TwinView yang sangat menyesal tidak bisa membantu lagi


Baru-baru ini saya telah meningkatkan sistem ke versi 11.10. Ubuntu 11.10 menggunakan pengelola tampilan baru (lightgdm) dan tampaknya layar masuk selalu muncul di monitor utama. Ini memecahkan masalah saya.


1
2017-12-03 20:12





cobalah mengalihkan urutan kiri / kanan monitor Anda, tidak mengubah yang mana yang utama, tetapi mungkin membantu membuat GDM Anda muncul.


0
2017-11-06 13:59



itu tidak membantu. - Kirill V. Lyadvinsky


Jika twinview melakukannya dengan cara yang sama dengan pusat kendali katalis ATI melakukannya, ada xorg.conf yang dapat Anda edit dengan gksu gedit /etc/X11/xorg.conf

Bagian yang relevan dari saya terlihat seperti ini:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-0" 0 0
    Screen         "amdcccle-Screen[1]-1" 1400 0
EndSection

Yang harus Anda lakukan (setelah mencadangkan xorg.conf Anda tentu saja) adalah mengubah ServerLayout dengan menukar entri Layar (dan mengadaptasi nomor layar), dalam kasus saya itu adalah:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-1" 1400 0
    Screen         "amdcccle-Screen[1]-0" 0 0
EndSection

0
2018-01-12 10:57



Saya hanya memiliki satu layar didefinisikan dalam xorg.conf jadi ini tidak membantu. - Kirill V. Lyadvinsky
@Kirill: bisakah Anda menukar colokan dan kemudian mengubah urutan layar di pengaturan nvidia? - Tobias Kienzler
Itu tidak membantu. Mouse selalu muncul di tengah penyatuan layar dan pusat selalu berada di monitor dengan resolusi yang lebih tinggi. Layar login selalu menunjukkan di mana kursor mouse berada. - Kirill V. Lyadvinsky


Anda dapat mencoba "Pengaturan layar X terpisah" pada pengaturan NVIDIA X Server. Jika Anda mengatur tampilan yang diinginkan ke 0, jendela login akan muncul di sana. Ini bekerja untukku.


0
2017-11-30 11:08



Saya sudah mencoba ini, tetapi Gnome3 crash setiap kali masuk dalam mode ini. - Kirill V. Lyadvinsky