Pertanyaan Bagaimana cara mengatur zoom default di evince?


Saya sangat suka bagaimana evince bekerja tetapi hal kecil ini membuat saya sangat terganggu. Ketika saya memilih judul atau subtitle dari menu konten, itu menggeser zoom dan saya akan menjadi gila. Pada jendela itu hanya mudah sekali dengan rubah tapi versi linux-nya benar-benar membutuhkan waktu. Setiap solusi atau saran akan membuat saya bersyukur


21
2017-11-06 21:08


asal


"Saat saya memilih judul atau subtitle dari menu konten, itu akan menggeser zoom". Bisakah Anda menjelaskan ini? Jika Anda bermaksud mengatakan bahwa level zoom berubah ketika memilih entri yang berbeda dalam daftar isi, itu bekerja dengan baik untuk saya. Apa sebenarnya yang terjadi ketika Anda memilih entri? - Glutanimate
ya saya selalu ingin diatur "fit page width" tetapi ketika saya memilih sebuah judul, itu mengubah sesuatu seperti "% 75" dan saya harus mengatur ulang ke "fit page width" setiap kali. Simpan pilihan saat ini tidak bekerja sejauh ini. - c.k.
Ya ya, terima kasih telah menanyakan ini, hanya apa yang saya butuhkan - Miguelgraz
gsettings mengatur org.gnome.Evince.Default sizing-mode 'fit-page' - The Demz


Jawaban:


ini harus bekerja.

buka terminal dan ketik:

gsettings set org.gnome.Evince allow-links-change-zoom false 

22
2018-04-23 16:29



Tidak ada kunci seperti 'perbolehkan-tautan-ubah-zoom'. menggunakan 12.04, evince 3.4.0 - Rashi
Terima kasih, ini sangat membantu! Tidak ada cara untuk mengatur perilaku ini melalui UI Evince. Anda dapat menyimpan pengaturan default, tetapi mengklik tautan bookmark mengganggu hal yang sama, kecuali Anda mengaturnya dari gsettings. - Prahlad Yeri
Tepat seperti ini, atur saja gsettings dan berbahagialah - Miguelgraz
Bung Terima kasih. - Tom


Untuk mengatur zoom default, Anda dapat mengaturnya dalam program dan kemudian pergi untuk mengedit> 'save current settings as default' atau pilih nilai Anda dan jalankan

gsettings set org.gnome.Evince.Default zoom 1.75

Namun, saya pikir apa yang Anda maksudkan adalah ketika, katakanlah Anda memiliki tingkat zoom besar 175% dan Anda memiliki sidebar diaktifkan dan mode berkelanjutan diaktifkan, bergulir ke halaman berikutnya mengganggu zoom. Ini membuat halaman menjadi pusat dan Anda harus menyesuaikannya secara manual setiap kali, seperti yang ditunjukkan di screenshot pertama di bawah.

Untuk mengubah perilaku ini, satu-satunya perbaikan adalah memilih opsi 'muat lebar halaman' dengan pergi ke tampilan> 'muat lebar halaman'. Lalu pergi untuk mengedit> 'save current settings as default'. Ini akan menghilangkan masalah ini, karena screenshot kedua menunjukkan, meskipun level zoom akan turun sedikit seperti Anda tidak bisa mengatur tingkat zoom dan mengaktifkan opsi 'fit page width'.

enter image description here 

enter image description here


9
2017-11-07 15:37



Masalahnya adalah saya tahu tentang fitur "simpan pengaturan saat ini sebagai default" tetapi ketika saya memilih konteks judul crom itu hanya mengubah zoom lagi. - c.k.
@ c.k. Setelan 'muat lebar halaman' mungkin adalah yang Anda butuhkan.
Saya dengan dengan OP. 'muat lebar halaman' + 'setel pengaturan saat ini sebagai default' tidak menyelesaikan masalah. Saya sudah mencoba kombo ini setidaknya selusin kali, tingkat zoom masih ulang kapan pun evince meluncurkan, dan kemudian (lebih mengganggu) setiap kali halaman dipilih dari sidebar / daftar isi. - justin cress
Setuju, tidak berfungsi. - Dodgie
Lihat askubuntu.com/a/612913/207451 - paulodiovani


Masalah ini tampaknya terkait dengan pengaturan apponfor dconf dan Evince. Solusi yang mungkin dimakamkan di tautan ini:

https://bugs.launchpad.net/ubuntu/+source/evince/+bug/682492

tl; dr

  1. Pertama, instal dconf-tools:

    apt-get install dconf-tools
    
  2. Kemudian konfigurasi ulang apparmor:

    sudo dpkg-reconfigure apparmor
    
  3. Konfigurasi akan meminta jalur ke folder rumah Anda. Yang umumnya:

    /home
    

Ini membantu saya.


1
2017-10-19 02:11





Sederhana jalankan $ dconf-editor kemudian org / gnome / evince atau cari melalui strg + f setelah membuka editor.
Kemudian ubah pengaturan default default / continuous / zoom dll.


0
2017-08-08 17:05