Pertanyaan Telah merobek (tidak ada Vsync) dalam film (driver proprietary Nvidia)


Ini lebih dari KDE daripada pertanyaan Ubuntu, tapi ...
Saya telah terlihat robek di layar. Komposisi KDE, flash video di Firefox, dan game-game sederhana seperti kpat yang ditiru, tapi dalam permainan uap dan film ada robekan konstan yang berbeda. Jika saya mematikan vsync di mana-mana, robekan menjadi dua kali lipat, jadi bukan hanya GPU yang mengabaikan pengaturan.
Apa yang paling mengganggu saya sehingga saya mengalami masalah yang sama pada banyak pengaturan yang berbeda. Apakah setiap orang memiliki masalah ini dan tidak ada yang peduli?
Pengaturan saya

  • Kubuntu (beberapa versi terakhir) atau OpenSuse atau Gentoo.
  • KDE 4.12 - 4.13
  • Nvidia GTX 260, 570, TITAN, versi driver yang berbeda.
  • Saya menonton film di SMplayer dengan backend mplayer2. VLC memiliki masalah yang sama.

Apa yang saya coba (dan itu tidak membantu)

  • Mengaktifkan dan menonaktifkan dalam berbagai konfigurasi pengaturan Vsync dalam pengaturan nvidia dan efek Desktop KDE.
  • Mengalihkan keluaran Mplayer dan direct rendering pengaturan.
  • Mematikan mode daya Adaptif dalam pengaturan nvidia.
  • Mematikan pengomposisian
  • Mengubah monitor Hz
  • Menjalankan mplayer dari CLI
  • Melakukan ritual dan pengorbanan

Apa yang berhasil (tetapi tidak dan solusi yang dapat diterima)

  • Menonaktifkan KDE, dan menjalankan Mplayer dalam sesi X murni
  • Beralih ke nouveau DAN mematikan komposisi DAN membuka video dalam layar penuh - tanpa bagian apa pun masih merobek.

Tolong saran.

PERBARUI 1 Saya menemukan bahwa jika saya pergi ke Desktop Effects - Advanced dan mengubah ada sesuatu yang berharga (versi OpenGL, skala algorythm) dan tekan Apply, robekan itu hilang sampai reboot. Namun, tidak ada pengaturan yang dapat memecahkan masalah ini sekali dan untuk selamanya. Setelah reboot saya harus pergi dan mengubah sesuatu lagi. Saya kira itu cukup untuk menyalahkan ini pada bug, bukan kesalahan saya, jadi saya akan mengajukan laporan bug.


18
2018-04-27 12:33


asal




Jawaban:


Panduan sederhana untuk memecahkan masalah yang menjengkelkan ini :)

  1. Buat file:

    /etc/profile.d/Tearing.sh
    
  2. Masukkan kode ini:

    export __GL_YIELD="USLEEP"
    
  3. Kemudian membuatnya dapat dieksekusi dengan:

    chmod +x /etc/profile.d/Tearing.sh
    
  4. Setelah selesai, reboot atau tekan ctrl + alt + F2, masuk dan jalankan sudo service lightdm restart Atau mulai ulang apa pun tampilan pengelola gambar Anda.

GL_YIELD bekerja untuk saya, dan sekarang sinkronisasi vertikal tampaknya berfungsi sebagaimana mestinya.

(https://www.kubuntuforums.net/showthread.php?63946-No-vertical-sync-with-NVIDIA&highlight=tearing)


8
2017-09-28 13:40



Ini berhasil, terima kasih! Tidak perlu lagi merobek setelah reboot - user1003916
Apakah trik untuk saya juga, nVidia GeForce 210 melalui HDMI ke TV - K0D4


Sumber masalahnya adalah (tentu saja) driver nvidia yang rusak. Solusinya sederhana. Tambahkan variabel lingkungan:

export __GL_YIELD="USLEEP"
export __GL_THREADED_OPTIMIZATIONS=1

suatu tempat sebelum X dimulai. System-wide /etc/profile/ bekerja dengan baik.


8
2017-09-27 08:27



Ini tidak membantu dalam 14.04 atau 16.04 - Giovanni Toraldo


Saya telah memaku ...

Jadi - pertama-tama pastikan untuk memeriksa apakah masalah tetap ada setelah Anda mematikan Desktop Effects (Alt + Shift + F10). Saya dapat menjamin bahwa masalahnya mungkin sudah hilang.

Buka Pengaturan Sistem dan buka Efek Desktop:

  • Metode Scaling untuk sesuatu yang lain dari yang ditetapkan saat ini <- memperbaiki aktual

Saya tahu pilihannya mungkin tidak disebutkan persis seperti di atas. Maaf tentang itu, tapi saya menggunakan Kubuntu versi Polandia.

Langkah-langkah di atas memperbaiki masalah untuk saya. Tetapi hanya setelah instalasi baru. :)

EDIT: Dalam versi Kubuntu 14.04 saat ini, masalahnya dihubungkan dengan Metode Penskalaan. Mengubahnya ke hal lain selain yang dipilih saat ini, membantu menyelesaikan masalah secara TEMPORARILY.


5
2018-04-28 15:37



Saya telah mencoba pengaturan "Metode Scaling untuk Menghaluskan" sendirian dan sepertinya memecahkan masalah! Tapi saya akan menunggu akhir pekan sebelum menutup jawabannya. Merobek menghilang untuk beberapa waktu dan muncul lagi, dan terlebih lagi, bahwa "mulus" hal seharusnya tidak berpengaruh pada saat film diputar. Aneh. Bahkan seram, kamu tahu. - Barafu Albino
Jadi sepertinya ini: Ketika saya mengubah metode skala ke apa pun, merobek menghilang. Tetapi setelah reboot, itu kembali, dan saya harus mengubahnya lagi menjadi sesuatu yang berbeda. - Barafu Albino
Ini memperbaiki masalah ini untuk saya. Saya pikir tidak semua langkah diperlukan, tetapi bersama-sama mereka tampaknya telah tertutup dan saya mendapatkan kinerja video hd yang indah (di VLC) di kedua jendela dan modus maksimal. Kombinasi pengaturan nvidia plus menonaktifkan efek desktop juga memperbaikinya, tetapi cara ini saya dapat membiarkan efek desktop diaktifkan. Juga saya menginstal paket ekstra ekstra ubuntu sebelumnya - tidak yakin apakah ini ikut bermain atau tidak. - Egg
Dan saya dapat "menjamin" bahwa jika Anda mematikan monitor Anda, masalah "mungkin" akan hilang juga :) Jangan tersinggung, tetapi jika masalahnya "mungkin" hilang, tidak ada jaminan sama sekali. Pokoknya poin saya adalah bahwa ini bukan resolusi yang dapat diterima untuk saya dan mungkin banyak orang lain tetapi mungkin membantu jika seseorang ingin hanya menonton satu film dan tidak menghabiskan banyak waktu di atasnya. - tomasb


Saya telah mencoba semua trik dan tidak ada yang diselesaikan pada Ubuntu 15.04 (bersama dengan xorg-edgers dan nvidia-355), sampai saya datang halaman nvidia archlinux.

Uji dengan:

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Untuk membuat perubahan permanen, Anda perlu menambahkan yang berikut baris ke "Layar" bagian dari file konfigurasi Xorg Anda, untuk contoh dalam /etc/X11/xorg.conf.d/20-nvidia.conf

Option  "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

5
2017-08-13 19:52



Menyalin dan menempel jawaban yang sama untuk banyak pertanyaan tidak begitu bagus. Anda seharusnya menandai sebagai duplikat, fakta bahwa pertanyaan-pertanyaan ini sudah menjawab. Terima kasih :) - Mitch♦
Terima kasih, saya mengalami robekan, dan solusi lain (seperti pengaturan variabel __GL_YIELD) tidak berfungsi. Juga, saya sebelumnya mengalami masalah dengan pengaturan file Xorg, tetapi baris perintah di atas berhasil bekerja. Saya akan mencoba menambahkan baris perintah ke ~ / .xprofile saya. Ini peretasan, tetapi seharusnya berhasil. - Chris
Tidak dapat memberi Anda cukup poin :-) Sebagai referensi, saya menggunakan Xubuntu 15.10 dengan nvidia-355. - Marcus
Ini bekerja untuk saya dan saya di 14.04 :) - Neil
Ini bekerja untuk saya di KDE Neon User LTE. - tejzpr


Menghapus driver NVIDIA terpecahkan untuk saya. Untuk XFCE, satu-satunya hal yang membantu adalah mengganti window manager.


0
2018-06-15 15:12



Untuk XFCE. Untuk WM lain, bagaimanapun, menghapus driver tidak diperlukan dan saya atau mungkin tidak menyelesaikan masalah. - Barafu Albino
Sepertinya sangat penting bagi saya, karena drivernya tidak jelas dan nouveau memberikan vsync yang saya perlukan. - Waterscroll
Apa window manager yang Anda gunakan? - jarno
Compton, tetapi saya menemukan sumber masalah saya. Ada masalah dengan nvidia optimus dan xorg yang menyebabkan robek ketika Anda menggunakan kartu nvidia Anda. - Waterscroll
Adapun vsync, membangun Xfwm4 dari Git membantu; instruksi adalah sini). Namun, versi Git saat ini tampaknya memiliki beberapa masalah menggambar lainnya. - jarno


Saya mencoba setiap saran untuk mencoba dan memperbaiki layar yang merobek saat menonton video di Unity, Gnome, dan Gnome Classic pada dua komputer (satu dengan Nvidia Titan X dan yang lainnya dengan kartu Radeon lama). Tidak ada yang berhasil.

Kemudian saya perhatikan bahwa ketika saya mengganti output video dalam pengaturan VLC saya dari OpenGL ke X11, robekannya hilang tetapi saya mulai mendapatkan banyak kotak hitam / putih acak atau "noise".

Agar pemutaran video berfungsi, saya menginstal Lubuntu Desktop yang menggunakan OpenBox alih-alih OpenGL. Lubuntu adalah turunan Ubuntu yang telah diinstal LXDE secara default. Ini sangat ringan dan sempurna untuk berjalan di latar belakang saat Anda menggunakan Kodi dan Steam, atau hanya menonton video.

Jendela robek dapat terjadi saat menyeret jendela dengan cepat, tetapi ini tidak masalah bagi saya dalam situasi ini karena saya hanya menggunakan Kodi dan Steam dalam mode layar penuh pada komputer ini.

Jalankan perintah berikut untuk menginstal LXDE dan vanilla LXDE yang disesuaikan di Ubuntu:

sudo apt-get install lubuntu-desktop

Gunakan perintah ini untuk menginstal hanya vanilla LXDE:

sudo apt-get install lxde

Anda juga dapat memberi LXDE putaran dengan mengunduhLive CD Lubuntu.

Setiap lingkungan hanya berbeda dalam pengaturan standarnya. Mereka datang dengan tema, wallpaper, dan tata letak panel yang berbeda. Misalnya, peramban Chromium adalah default di Lubuntu, sementara Mozilla Firefox adalah default pada vanilla LXDE. Tentu saja, Anda dapat menggunakan browser apa pun yang Anda suka. Mereka berdua menggunakan file manager PCManFM, pengganti ringan untuk file manager Nautilus yang ditemukan di GNOME.

Setelah menginstal salah satu paket, keluar dan pilih salah satu dari sesi Lubuntu atau LXDE dari layar login.

Video saya tidak pernah terlihat lebih baik daripada di Lubuntu. Saya bisa menabrak frekuensi saya hingga 120Hz untuk mencocokkan TV saya. Pemutarannya sangat mulus untuk 1920x1080p.


0
2017-07-12 01:19



OpenBox bukan OpenGL? Apakah mereka untuk tugas yang sama? - jarno
Tidak, saya menyarankan Anda menggunakan jendela manajer pengomposisian, seperti Openbox, yang tidak menggunakan OpenGL. en.m.wikipedia.org/wiki/Compositing_window_manager - guttermonk
Xfce4 menggunakan Thunar sebagai manajer file secara default, bukan PCManFM. - jarno
Menjalankan LXDE tidak menghentikan video yang merobek di browser Chromium saat bermain YouTube. Saya memiliki grafik Intel, dan ubuntu 14.04. - jarno
@Jarno, XFCE adalah salah ketik. Saya telah mengeditnya dan menggantinya dengan LXDE. Mengenai layar yang merobek, apakah Anda mencoba browser yang berbeda? Apakah Anda memiliki layar yang merobek ketika Anda memutar file video dari hard drive Anda? - guttermonk