Pertanyaan Ubuntu 14.04 macet saat shutdown


Ketika saya mencoba mematikan komputer saya, itu tergantung di layar shutdown dan ini adalah satu-satunya baris yang bisa saya lihat:

wait-for-state stop/waiting
Stoping GNUstep distributed object mapper: gdomap.
* Stopping rsync daemon rsync [ OK ]
* Stopping Speech Dispatcher speech-dispatcher [ OK ]

Dan itu semua.

Saya menggunakan gnome 3.10 (memiliki 3.12 tetapi diturunkan karena beberapa masalah) jika ada hubungannya dengan itu.

Reboot komputer berfungsi; itu tidak menggantung.


14
2017-08-07 09:51


asal




Jawaban:


Dalam kasus saya, langkah-langkah sederhana ini berhasil untuk saya:

  1. tekan Ctrl+Alt+T untuk masuk ke terminal dan mengetik:

    sudo gedit /etc/default/grub
    

    Ini akan membuka file konfigurasi grub. Ubah baris:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    untuk:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off"
    

    Lalu simpan & tutup.

  2. Ketik di terminal yang sama:

    sudo gedit /etc/modules
    

    Ini akan membuka konfigurasi modul, cukup tambahkan yang berikut:

    apm power_off=1
    

    dan simpan file.

  3. Tipe selanjutnya di terminal:

    sudo update-grub
    

Sumber


13
2018-01-13 10:59



@Fabby kamu benar, terima kasih. Saya telah menambahkan langkah-langkah =) - Uroš Podkrižnik
Jauh lebih baik! Dan pengeditan dan sebuah upvote! Bisakah Anda tinjau saya hasil edit dan juga meninjau mengedit bantuan untuk meningkatkan keterbacaan jawaban Anda di masa depan ... ;-) - Fabby
aku percaya acpi=force milik dalam kutipan, karena saya telah melihat banyak tempat di tempat lain (lihat satu contoh). Jawaban di bawah ini juga memiliki apm=power_off bagian dalam tanda kutip. - Nateowami


Ubuntu tidak shutdown dengan benar atau macet saat shutdown?

Masalah yang dihadapi Saat memasang Ubunutu 14.04 di Dell XPS 15Z Laptop

Buka file /etc/default/grub dengan editor teks pilihan Anda, dan dengan admin privillege. Bisa dilakukan dengan gksu gedit /etc/default/grub untuk editor teks GUI atau sudo nano /etc/default/grub untuk akses command-line.

Temukan baris berikut:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Gantilah dengan yang berikut:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq acpi=force apm=power_off quiet splash"

Simpan dan tutup file. Kembali di terminal mengeksekusi:

 sudo update-grub

Sekarang, ketika Anda mematikan, itu harus bekerja.


7
2017-08-07 09:58



Hang saat shutdown. Saya mencoba ini tetapi masalah yang sama tetap ada. - user313246
Untuk Razer Blade 14, solusi Anda membantu. Terima kasih. Saya menjatuhkan acpi=noirq karena tidak ada bedanya dalam kasus saya. - topr


Saya baru saja menghapus quiet splash dari baris ini di /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

dan berlari sudo update-grub

dan itu tidak pernah berhenti saat shutdown lagi


3
2017-12-17 02:48



Saya menghapus dan sekarang laptop saya tidak macet saat shutdown / reboot. Terima kasih. - Mustafa Chelik


Saya menggunakan Lubuntu 16.04.1. Saya mencoba beberapa metode termasuk: mengedit /etc/default/grub, lari sudo swapoff -a sebelum shutdown, dll ... Tapi tidak satupun dari mereka yang bekerja untuk saya.

Mematikan USB 3.0 legacy mode di BIOS bekerja untuk saya.


2
2017-07-29 02:14





Saya mencoba untuk menggosok perubahan tanpa keberhasilan. Saya harus menggunakannya sudo shutdown -h 0 (begitu dengan -h) untuk membuatnya bekerja.

Jika saya lupa -h, sistem hang dengan saya berpotensi jauh, jadi saya membuat alias untuk itu (biasanya bukan ide yang baik untuk perintah builtin alias tapi saya merasa ini penting).

alias sudo='sudo '  # note the space, that's what makes sudo recognize aliasses
alias shutdown='shutdown -h'

1
2017-08-02 15:41





Saya memiliki masalah yang sama dengan shutdown pada Ubuntu (15.10 dan 16.10). Dengan debug diaktifkan di GRUB saya bisa melihat bahwa laptop jatuh tepat setelah 'mencapai target Shutdown'

GRUB_CMDLINE_LINUX_DEFAULT="debug"

Saya juga mencoba berbagai opsi GRUB dan bahkan untuk membuat layanan yang mematikan USB.

Jika Anda memiliki USB 3.0 Anda dapat mencoba untuk menonaktifkannya dari BIOS (saya tidak dapat melakukannya pada ASUS X540SA saya karena beberapa pengaturan di BIOS)

Bagi saya, solusinya adalah meng-upgrade kernel. Saya menggunakan 4.5.3 pada Ubuntu 15.10 (sesuatu yang lebih besar dari ini akan merusak OS setelah login) Dan 4,7 RC3 bekerja pada Ubuntu 16.04.

Sebelumnya saya menginstal Linux Mint 17 dan tidak ada masalah pada reboot / shutdown.


1
2018-06-20 08:11



Sialan! Terima kasih banyak! Saya sudah mencoba memperbaikinya selama beberapa hari sekarang. Menonaktifkan Pre-OS USB 3.0 Configuration dari pengaturan BIOS saya memperbaikinya. - Sheharyar


Saya mengalami hal yang sama pada laptop ASUS saya dan mencoba setiap metode untuk menghadapinya di bawah matahari. Salah satu yang mendapat terjauh adalah memperbarui kernel menjadi 4.2.3, jadi jika Anda ingin mencobanya klik disini dan ikuti instruksi.

Kegagalan itu, Anda selalu dapat jatuh kembali pada SysRq, yang adalah apa yang saya lakukan. Jika Anda berniat untuk menggunakan SysRq maka Anda harus benar-benar mengikuti langkah REISUB, tetapi sebenarnya, jika Anda perlu melakukannya sering seperti yang saya lakukan, maka semua kecuali B (atau O dalam kasus kami) tidak terlalu penting.

Tahan Alt+Prt Sc/SysRq+Shift kunci dan ketik REISUO, pastikan untuk menunggu sekitar 5-10 detik antara masing-masing dan komputer Anda akan dimatikan.

Penjelasan:

 R - Forces capturing of the keyboard
 E - Terminates all processes
 I - Kills all processes
 S - Syncs all mounted drives
 U - Remounts all drives in read-only mode

Kemudian:

 B - Reboots the system
 O - Shuts down the system

Itu karena menunggu lama yang dibutuhkan antara setiap entri yang saya kurangi pada yang tidak perlu; plus, sebagian besar hanya diperlukan jika Anda kehilangan kendali atas sistem. Jadi jika Anda mencoba mematikan secara manual dan membeku, seperti yang ingin dilakukan, ikuti REISUO ... jika tidak, gunakan saja O.

(Ingat bahwa itu tidak akan terjadi segera, jadi jangan terus menekan untuk membuatnya bekerja lebih cepat; bersabar saja).

Sebagai catatan tambahan: beberapa komputer mungkin menggunakan kombinasi tombol yang berbeda, seperti Alt+Fn+Prt Sc/SysRq. Ada lebih banyak detail sini di halaman Wikipedia dengan pola alternatif yang dapat Anda coba jika dokumen asli tidak berfungsi.

Semoga ini semua membantu.


0
2017-12-12 03:42





Saya memiliki masalah yang sama dan tidak ada yang menyarankan untuk berhasil. Akhirnya saya tahu bahwa sistem itu diatur untuk boot menggunakan LEGACY dan tidak UEFI Aman. Setelah saya mengubahnya ke UEFI, itu berhasil dengan sempurna!


0
2018-01-16 22:11





Saya memiliki masalah yang sama dan butuh waktu 3 hari untuk menyelesaikannya.

Saya menggunakan Lenovo B50-10. Instalasi Ubuntu 14.04 tidak menimbulkan masalah sampai saya ingin me-restart komputer untuk menyelesaikan proses instalasi. Layar berubah menjadi hitam dan komputer tidak akan melakukan apa-apa. Segera saya tahu bahwa itu tidak akan ditutup juga. Hard drive dimatikan tetapi layar membeku menunjukkan logo ubuntu dengan titik-titik.

Jadi saya mencoba memodifikasi opsi boot dengan mengedit

GRUB_CMDLINE_LINUX_DEFAULT = "percikan tenang"

garis dan menerapkan solusi yang disebutkan dalam jawaban di atas.

Kemudian saya tahu bahwa saya menginstal Ubuntu dalam mode legacy dan ini mungkin alasannya. Jadi saya mengubah mode BIOS ke UEFI dan menginstalnya dalam mode UEFI. Anehnya saya sekarang bisa menghentikan Ubuntu dari berhenti di shutdown / kirim ulang dengan mengedit

GRUB_CMDLINE_LINUX_DEFAULT = "acpi = noirq quiet splash"

Sayangnya modifikasi ini menyebabkan saya tidak memiliki koneksi wifi lagi. Jadi itu bukan solusi yang benar-benar dan saya mempertimbangkan memperbarui BIOS dan kernel. Tapi tanpa kunci produk Windows dan pemula linux yang berdarah karena saya tidak tahu caranya.

Tetapi akhirnya saya memecahkan masalah dengan menerapkan solusi ini:

Pergi ke bios dan ubah "OS Optimized Defaults" dan atur ke "Enabled". Kemudian tekan "Load default settings".

Inilah solusi yang berhasil bagi saya. Jadi saya tidak perlu memperbarui firmware atau kernel.


0
2018-02-25 13:20





Saya masih memiliki masalah yang sama, meskipun mengikuti saran,

Berikut ini adalah hasil dari

sudo gedit / etc / default / grub

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off"
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=bios"
GRUB_CMDLINE_LINUX=""

Dan output dari

sudo gedit / etc / modules

lp
rtc
apm power_off=1

Terima kasih,


-1
2018-05-12 09:12